Bug 18787 - cvspserver does not work with xinetd
cvspserver does not work with xinetd
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-10-10 05:08 EDT by mikak
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-12 01:37:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mikak 2000-10-10 05:08:34 EDT
After upgrading to RH 7.0 cvspserver stopped working correctly.
The cvs is called with wrong arguments by xinetd so this is due to
changing from inetd to xinetd.

The problematic part seems not only be the conversion from inetd
files to xinetd ones, but rather the way xinetd parses server_args.

/etc/xinetd.d/cvspserver includes:
   server = /usr/bin/cvs
   server_args = cvs --allow-root=/some/dir pserver
I removed 'cvs' from server_args but that not having been helpful I
out that the problem lies probably in the equals sign '='  within
arguments. This
results in cvs being called with erraneous args when connecting to
cvspserver port.

As a workaround I created a shell script that calls cvs with correct
arguments which seems
to work for now.
Comment 1 Tim Waugh 2000-10-10 08:58:32 EDT
If you use:

  server = /usr/bin/cvs
  server_args = --allow-root=/some/dir pserver

and do 'service xinetd reload', do things work? (I.e. had you restarted xinetd
after changing the cvspserver file?)
Comment 2 mikak 2000-10-10 09:24:41 EDT
Of course. Otherwise the workaround script would not have worked either.
In other words: restarting does not help. As I telnetted to port 2401, with
those server_args, the cvs responded with the list of commands i.e. the
'pserver' argument did not seem to make its way through xinetd. 
If --allow-root=... is removed it works as it should, (denying the tried
directory, this, however is not of much use). 
Comment 3 Trond Eivind Glomsrxd 2000-10-10 10:07:55 EDT
How does the entire file in /etc/xinetd.d/ look?
Comment 4 mikak 2000-10-12 01:37:14 EDT
Well, well. Tried it again, and without 'cvs' in server_args it seems to work
fine after all. Obviously as I was trying out various combinations I forgot to
restart xinetd after this very first try and went straight to the other

So, the only bug was that 'cvs' itself was included in server_args which, I
guess, was already reported. Sorry for the inconvenience :-)

Note You need to log in before you can comment on or make changes to this bug.