Bug 1878794 - Azure: pod on the pod network cannot dial internal/external kube-apiserver load balancer
Summary: Azure: pod on the pod network cannot dial internal/external kube-apiserver lo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Ricardo Carrillo Cruz
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1877880 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 14:22 UTC by David Eads
Modified: 2020-10-27 16:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2089 0 None closed Bug 1878794: handle azure vips for pods 2021-02-10 20:42:47 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:07 UTC

Internal Links: 1877880

Description David Eads 2020-09-14 14:22:07 UTC
See https://prow.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-4.6/1305155086455934976

1. all kube-apiservers are functioning
2. the kube-apiserver (host network) can reach the internal/external load balancer consistently.
3. the openshift-apiserver (pod network) can access each kube-apiserver by direct IP
4. the openshift-apiserver (pod network) canNOT access the internal/external load balancer consistently.  Our connectivity check in must-gather shows connection interruptions every third attempt or so to the load balancers.

To summarize, the host network to LB access works.  The pod network to LB access does not work reliably.

Comment 1 Stefan Schimanski 2020-09-14 14:28:41 UTC
The logic around https://github.com/openshift/machine-config-operator/blob/master/templates/master/00-master/gcp/files/opt-libexec-openshift-gcp-routes-sh.yaml#L60 is missing in the Azure script. It matches the symptoms of non-local clients (e.g. pod network namespace) not being able to contact the LB 1/3 of the time.

Comment 5 zhaozhanqi 2020-09-23 06:27:17 UTC
Verified this bug on 4.6.0-0.nightly-2020-09-22-051033

rsh into openshift-apiserver pod and then try to curl the external LB 20 times,  all of them success 

oc rsh -n openshift-apiserver apiserver-74b6465579-6zdpc

for i in `seq 20` ; do curl -I --connect-timeout 5 https://api.zzhaoazu.qe.azure.devcluster.openshift.com:6443 -k ; done

Move this bug to 'verified'

Comment 6 Luis Sanchez 2020-10-02 14:11:32 UTC
*** Bug 1877880 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2020-10-27 16:40:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.