Bug 1878833 - CCO vendoring unreleased controller-runtime
Summary: CCO vendoring unreleased controller-runtime
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Joel Diaz
QA Contact: wang lin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 15:40 UTC by Joel Diaz
Modified: 2020-10-27 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 247 0 None closed Bug 1878833: Update vendoring for 4.6 2020-10-20 14:25:59 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:07 UTC

Description Joel Diaz 2020-09-14 15:40:35 UTC
Description of problem:
CCO vendoring semi-custom version of controller-runtime

Version-Release number of selected component (if applicable):
latest

How reproducible:
100%

Steps to Reproduce:
1. view CCO's go.mod
2.
3.

Actual results:
replace sigs.k8s.io/controller-runtime => github.com/joelanford/controller-runtime v0.2.0-beta.1.0.20200723141319-3249b9ca8d12

Expected results:
sigs.k8s.io/controller-runtime v0.6.2


Additional info:

Comment 3 wang lin 2020-09-17 02:42:08 UTC
The version of controller-runtime has updated to v0.6.2, and main functions did't regression.
test payload: 4.6.0-0.nightly-2020-09-16-050052

Comment 6 errata-xmlrpc 2020-10-27 16:40:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.