Bug 1878916 - Chromium package might have missing OpenGL libraries (libGLESv2.so and libGLESv2.so) - Only SW acceleration
Summary: Chromium package might have missing OpenGL libraries (libGLESv2.so and libGLE...
Keywords:
Status: CLOSED DUPLICATE of bug 1877268
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 32
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 21:51 UTC by sergiopf
Modified: 2020-09-14 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 22:07:46 UTC
Type: Bug


Attachments (Terms of Use)

Description sergiopf 2020-09-14 21:51:31 UTC
Description of problem:
Chromium seems not to be using any hardware acceleration by default

Version-Release number of selected component (if applicable):
chromium-85.0.4183.83-1.fc32.x86_64


How reproducible:
Installing chromium and executing it.

Steps to Reproduce:
1. Run dnf install -y chromium
2. Run chromium from a Terminal to see the logs

Actual results:
about:gpu shows that only SW acceleration is available

Error message in the terminal:

```
[24269:24269:0914/234130.187901:ERROR:gl_implementation.cc(286)] Failed to load /usr/lib64/chromium-browser/libGLESv2.so: /usr/lib64/chromium-browser/libGLESv2.so: cannot open shared object file: No such file or directory
```

If this is fixed adding a symbolic link, I get the same error for libEGL.so.

After fixing the symbolic links:
```
ln -s /usr/lib64/libGLESv2.so.2 /usr/lib64/chromium-browser/libGLESv2.so
ln -s /usr/lib64/libEGL.so.1 /usr/lib64/chromium-browser/libEGL.so
```

This error is printed in a loop while chromium is opened:
```
[24785:24785:0914/234446.816784:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[24785:24785:0914/234446.820293:ERROR:gl_surface_egl.cc(741)] EGL Driver message (Error) eglCreateContext: eglCreateContext
[24785:24785:0914/234446.820746:ERROR:gl_context_egl.cc(233)] eglCreateContext failed with error EGL_BAD_ATTRIBUTE
[24785:24785:0914/234446.820996:ERROR:gpu_channel_manager.cc(711)] ContextResult::kFatalFailure: Failed to create shared context for v
irtualization.
```

However, Chromium seems to be reporting that there is HW acceleration


Expected results:

HW acceleration working in Chromium
Additional info:
Hardware: ThinkPad x230 - i5 3230M

Comment 1 Tom "spot" Callaway 2020-09-14 22:07:46 UTC

*** This bug has been marked as a duplicate of bug 1877268 ***


Note You need to log in before you can comment on or make changes to this bug.