Bug 1879068 - Collect hostsubnet information
Summary: Collect hostsubnet information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Tomas Remes
QA Contact: psimovec
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks: 1880352
TreeView+ depends on / blocked
 
Reported: 2020-09-15 11:34 UTC by Tomas Remes
Modified: 2020-10-27 16:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Insights Operator gathers anonymized HostSubnet resource configuration. Reason: Result: Anonymized HostSubnet configuration is collected by Insights Operator.
Clone Of:
: 1880352 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:41:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift insights-operator pull 177 0 None closed Bug 1879068: Collect hostsubnet information 2020-10-22 10:21:53 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:30 UTC

Description Tomas Remes 2020-09-15 11:34:44 UTC
Description of problem:

Collect hostsubnet cluster information

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 psimovec 2020-09-18 16:56:22 UTC
Expected:
1.
2.
3.
4. latestArchiveFiles output contains some hostsubnet files

Verification steps:
1. Ask for cluster-bot for cluster
2. Set KUBECONFIG env variable accordingly
3. run helper function insights-operator/test/integration/main_test.go::latestArchiveFiles 
4. output contains
...
config/hostsubnet/ip-10-0-156-237.ec2.internal.json
config/hostsubnet/ip-10-0-165-129.ec2.internal.json
config/hostsubnet/ip-10-0-228-21.ec2.internal.json
...

Automated test will be simple check - Does latestArchiveFiles output contain at least 1 file in format config/hostsubnet/ip-*.json ?

VERIFIED on 4.6.0-0.ci-2020-09-18-113850

Comment 5 errata-xmlrpc 2020-10-27 16:41:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.