Bug 187907 - CUPS is unable to print some documents
CUPS is unable to print some documents
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 08:55 EDT by Vaclav "sHINOBI" Misek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: cups-1.2-0.3.rc2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-15 18:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CUPS debug output (23.49 KB, text/plain)
2006-04-04 08:55 EDT, Vaclav "sHINOBI" Misek
no flags Details

  None (edit)
Description Vaclav "sHINOBI" Misek 2006-04-04 08:55:17 EDT
Description of problem:
The document is not printed and is left in queue.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-33.3

How reproducible:
Always

Steps to Reproduce:
1. Print some documents (maybe some which has czech or some special characters
in name).
2.
3.
  
Actual results:
Document is not printed.

Expected results:
Should work.

Additional info: I noticed this problem for HP Deskjet 5550 as well as for HP
Color LaserJet 3550 (error log is attached). Some documents are printed without
problems, so I suppose it must be something specific to the content or the names
of documents.
Comment 1 Vaclav "sHINOBI" Misek 2006-04-04 08:55:17 EDT
Created attachment 127290 [details]
CUPS debug output
Comment 2 Tim Waugh 2006-04-04 11:05:35 EDT
Please show me the output of this command:

rpm -q ghostscript hplip hpijs cups
Comment 3 Vaclav "sHINOBI" Misek 2006-04-04 17:01:21 EDT
Ooops, I forgot to add this info :-(

ghostscript-8.15.1-7
ghostscript-8.15.1-7
hplip-0.9.10-1.1
hpijs-0.9.10-1.1
cups-1.2-0.2.rc1.2.5
Comment 4 Tim Waugh 2006-04-06 06:45:59 EDT
E [04/Apr/2006:14:32:35 +0200] [Job 320] Error: /undefined in SOB
E [04/Apr/2006:14:32:35 +0200] [Job 320] Operand stack:
E [04/Apr/2006:14:32:35 +0200] [Job 320]
E [04/Apr/2006:14:32:35 +0200] [Job 320] Execution stack:
E [04/Apr/2006:14:32:35 +0200] [Job 320] %interp_exit   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval-- --nostringval--   --nostringval--   false   1   %stopped_push  
1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3  
%oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval-- 
 2   %stopped_push   --nostringval--
E [04/Apr/2006:14:32:35 +0200] [Job 320] Dictionary stack:
E [04/Apr/2006:14:32:35 +0200] [Job 320] --dict:1138/1686(ro)(G)--  
--dict:0/20(G)--   --dict:80/200(L)--
E [04/Apr/2006:14:32:35 +0200] [Job 320] Current allocation mode is local
E [04/Apr/2006:14:32:35 +0200] [Job 320] Last OS error: 29
E [04/Apr/2006:14:32:35 +0200] [Job 320] ESP Ghostscript 815.01: Unrecoverable
error, exit code 1

These errors come from ghostscript, and suggest that the problem is specific to
the particular file you are trying to print.  Could you attach it please?
Comment 5 Vaclav "sHINOBI" Misek 2006-04-06 09:38:48 EDT
Hmm after further testing it seems that with the current versions I noticed this
problem exclusively when printing mails from Thunderbird, but I'm sure I
expected the same prob for some PDFs, but I'm affraid I deleted them after printing.
From Thunderbird this bug seems to appear when I try to print any email. Is
there any way I can capture ps output from thunderbird?

ghostscript-8.15.1-7
ghostscript-8.15.1-7
hplip-0.9.10-1.2
hpijs-0.9.10-1.2
cups-1.2-0.2.rc1.2.6
thunderbird-1.5-6
Comment 6 Vaclav "sHINOBI" Misek 2006-04-07 04:30:29 EDT
Just a wild guess, isn't the real problem in thunderbird and firefox print
system? I noticed today that it's impossible to print from firefox as well.
Comment 7 Tim Waugh 2006-04-07 04:34:14 EDT
Vaclav: if you have CUPS 1.2 installed, that is much more likely to be the problem.

How about if you go to the 'queue options' screen in system-config-printer, and
change the 'fitplot' option to 'false'?
Comment 8 Vaclav "sHINOBI" Misek 2006-04-07 06:17:36 EDT
Yup, great advice Tim, it helped in most cases (BTW maybe this notice should be
added to FAQ or release notes). There is still one document resisting, it's the
email from bank about validation of outgoing payments so I don't want to share
it to public :-). The bug report is just for this email message.
Comment 9 Tim Waugh 2006-04-07 06:43:37 EDT
Thanks for testing it.

I have reported this pstops bug upstream:
  http://cups.org/str.php?L1542
Comment 10 Jacek Pliszka 2006-04-15 13:40:33 EDT
I have very similar problem with pdftops output. I am the author of a  tax
filling program and I use pdftops to convert tax forms from .pdf.  This is the
original pdf:

http://www.mf.gov.pl/_files_/podatki/od_osob_fizycznych/pit_2005/rozliczenie_roczne/pit_d.pdf

I can not use pdf2ps since it is extremely ugly. Anyway the error I get is:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   1   4   %oparray_pop   --nostringval--   --nostringval--  
--nostringval--   --dict:1/2(L)--   --nostringval--   1   %dict_continue
Dictionary stack:
   --dict:1120/1686(ro)(G)--   --dict:0/20(G)--   --dict:81/200(L)--  
--dict:68/75(L)--
Current allocation mode is local
ESP Ghostscript 815.01: Unrecoverable error, exit code 1
Comment 11 Tim Waugh 2006-04-15 18:26:35 EDT
Jacek: are you seeing that error when printing through CUPS?  If not, please
file  a separate bug report.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.