Bug 1879089 - TriggerTemplates Deprecate Param References
Summary: TriggerTemplates Deprecate Param References
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Christoph Jerolimov
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1883225
TreeView+ depends on / blocked
 
Reported: 2020-09-15 12:30 UTC by Christoph Jerolimov
Modified: 2020-10-27 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
TriggerTemplates Deprecate Param References (82.79 KB, image/png)
2020-09-23 20:41 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6627 0 None open Bug 1879089: Use new parameter prefix (tt.param.) for Tekton Trigger version 0.6+ 2020-09-21 13:40:39 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:30 UTC

Description Christoph Jerolimov 2020-09-15 12:30:39 UTC
Description of problem:
Part of Tekton Triggers v0.6.0 comes a deprecation notice that changes the way parameters are referenced. The UI makes a note to inform the user how to approach using variables and this will need to be updated.

Version-Release number of selected component (if applicable):
OpenShift Pipelines Operator 1.1.0+

How reproducible:
Always

Steps to Reproduce:
1. Create a Pipeline
2. Open the "Add Trigger" modal from the kebab menu on the Pipeline

Actual results:
The info highlight shows a hint "$(params.parameter)"

Expected results:
The info highlight should be changed to "$(tt.params.parameter)"

Additional info:
Future build - this is a deprecation notice that needs to only be implemented once TP2 (1.1) of the Operator is released.

We have until v0.7.0 (v1.2 of the Operator, aka TP3) to implement this change before we start misleading the user. There shouldn't be any code break as it's entirely user driven input.

v0.6.0 Docs on Parameters https://github.com/tektoncd/triggers/blob/v0.6.0/docs/triggertemplates.md#parameters

Comment 2 spathak@redhat.com 2020-09-23 20:41:47 UTC
Created attachment 1716141 [details]
TriggerTemplates Deprecate Param References

Comment 3 spathak@redhat.com 2020-09-23 20:42:23 UTC
Verify on build version: 4.6.0-0.nightly-2020-09-22-130743
Browser version: Chrome 84

Comment 6 errata-xmlrpc 2020-10-27 16:41:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.