Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1879101 - [UI] Kebab action menu of 'Volume Snapshot Contents' lists items as 'Volume Snapshot'
Summary: [UI] Kebab action menu of 'Volume Snapshot Contents' lists items as 'Volume S...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Ankush Behl
QA Contact: Neha Berry
URL:
Whiteboard:
Depends On: 1877860
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-15 13:00 UTC by Jilju Joy
Modified: 2020-10-27 16:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing the kebab action items (103.47 KB, image/png)
2020-09-15 13:00 UTC, Jilju Joy
no flags Details
Click on 'Edit Labels' (101.75 KB, image/png)
2020-09-15 13:05 UTC, Jilju Joy
no flags Details
Click on 'Edit Volume Snapshot' (79.57 KB, image/png)
2020-09-15 13:05 UTC, Jilju Joy
no flags Details
Click on 'Delete Volume Snapshot' (99.21 KB, image/png)
2020-09-15 13:06 UTC, Jilju Joy
no flags Details
Screenshots for verification (673.95 KB, application/zip)
2020-09-25 09:12 UTC, Neha Berry
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6448 0 None closed Bug 1877860: Volume Snapshot basic CRUD tests 2020-10-12 06:30:36 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:30 UTC

Description Jilju Joy 2020-09-15 13:00:12 UTC
Created attachment 1714924 [details]
Screenshot showing the kebab action items

Description of problem (please be detailed as possible and provide log
snippests):
Kebab action of 'Volume Snapshot Contents' lists the action items as 'Volume Snapshot' and also redirects to a wrong page if clicked on any item.

The page will be redirected as explained below. Screenshots will be attached in next comment. 
1. Click on 'Edit Labels' in the kebab action.
"Labels for VS snapcontent-97601aa8-15f9-4486-83d1-07cc91be1b0e" where kind is VS(VolumeSnapshot) instead of VSC.
2. Click on 'Edit Volume Snapshot'.
"404: Not Found"
3. Click on 'Delete Volume Snapshot'.
"Delete Volume Snapshot?" confirmation.


====================================================================
Version of all relevant components (if applicable):
Cluster version is 4.6.0-0.nightly-2020-09-15-005959
ocs-operator.v4.6.0-77.ci


Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?
Yes

Is there any workaround available to the best of your knowledge?
No


Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?
1

Can this issue reproducible?
Yes


Can this issue reproduce from the UI?
UI specific issue


If this is a regression, please provide more details to justify this:


Steps to Reproduce:
1. Create a snapshot of a PVC.
2. In UI, go to Storage -> Volume Snapshot Contents
3. From the list of volume snapshot contents, click on kebab action menu of one volume snapshot content.
4. Click on each item in kebab action menu to see the behaviour.


Actual results:
In step 3, each action item is listed as 'Volume Snapshot' instead of 'Volume Snapshot Content.
Step 4 result is as explained under 'Description of problem'.


Expected results:
The kind should be 'Volume Snapshot Content'. By clicking each item, appropriate  page should be opened.

Additional info:

Comment 2 Jilju Joy 2020-09-15 13:05:16 UTC
Created attachment 1714926 [details]
Click on 'Edit Labels'

Comment 3 Jilju Joy 2020-09-15 13:05:54 UTC
Created attachment 1714927 [details]
Click on 'Edit Volume Snapshot'

Comment 4 Jilju Joy 2020-09-15 13:06:36 UTC
Created attachment 1714928 [details]
Click on 'Delete Volume Snapshot'

Comment 6 Neha Berry 2020-09-25 09:12:06 UTC
Created attachment 1716556 [details]
Screenshots for verification

Verified the fix in

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-25-014731   True        False         44m     Cluster version is 4.6.0-0.nightly-2020-09-25-014731
[nberry@localhost dc-cp-sep25]$ oc get csv
NAME                         DISPLAY                       VERSION        REPLACES   PHASE
ocs-operator.v4.6.0-569.ci   OpenShift Container Storage   4.6.0-569.ci              Succeeded


Attached the screenshots for verification.

Comment 9 errata-xmlrpc 2020-10-27 16:41:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.