Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1879164 - Decorator for Knative revision should show up for Revision if unique route is available
Summary: Decorator for Knative revision should show up for Revision if unique route is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Karthik Jeeyar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-15 14:57 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6631 0 None closed Bug 1879164: fixes route decorator to show up if unique route is there for that revision 2020-10-15 14:25:24 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:40 UTC

Description Jaivardhan Kumar 2020-09-15 14:57:33 UTC
Description of problem: Decorator for Knative revision should have route if unique route is available

Prerequisites (if any, like setup, operators/versions): Install Serverless operator

Steps to Reproduce
1. Create a ns "Sample-app"
2. Deploy an image as knative service , wait for revision to come up
3. Edit any property via edit form or yaml, wait for new revision to come to come up
4. Split traffic via context menu in topology among both revisions created above with 50-50

Actual results: can see decorator on both revisions and KSVC points to same route

Expected results: Decorator for Knative revision should have route only if unique route is available

Reproducibility (Always/Intermittent/Only Once): Always

Build Details: 4.6.0-0.nightly-2020-08-02-091622

Comment 2 Karthik Jeeyar 2020-09-23 08:11:17 UTC
Verified on
BUild : 4.6.0-0.nightly-2020-09-22-213802
Url : https://console-openshift-console.apps.jakumar-22091122.devcluster.openshift.com/topology/ns/test-ns/graph?selectId=4eebf10e-c1d7-413d-b0c2-2820a5054644
user : Kubeadmin

Comment 5 errata-xmlrpc 2020-10-27 16:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.