Bug 1879171 - Navigating to Topology from a URL with a selected item loses selection
Summary: Navigating to Topology from a URL with a selected item loses selection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-15 15:19 UTC by Jeff Phillips
Modified: 2020-10-27 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6633 0 None closed Bug 1879171: Fix for lost selectedId param in URL when navigating to topology 2020-09-23 07:39:44 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:40 UTC

Description Jeff Phillips 2020-09-15 15:19:45 UTC
Description of problem:

Going to Topology with a URL containing a selected item does not show the item selected and the URL loses the selected item parameter

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. Navigate to Topology
2. Select a node
3. Copy the current URL (with the selectedId parameter)
4. Navigate elsewhere
5. Paste the URL back to the browser location

Actual results:

Topology page is shown with no selection

Expected results:

Topology page is shown with previous item selected and URL still contains the pasted text.

Additional info:

Comment 2 Jaivardhan Kumar 2020-09-23 07:40:10 UTC
Verified on Version: 4.6.0-0.nightly-2020-09-22-213802

Comment 5 errata-xmlrpc 2020-10-27 16:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.