Bug 187924 - Unable to remote connect to FC5 - xdmcp
Unable to remote connect to FC5 - xdmcp
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 12:08 EDT by Peter Meyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 09:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Meyer 2006-04-04 12:08:39 EDT
Description of problem:
I am unable to host remote sessions using XDMCP using FC5. I've enabled remote
access via gdmsetup.  Is there something missing in the /etc/gdm/custom.conf
file or do we have a basic tool bug?

Version-Release number of selected component (if applicable):


How reproducible:
Set up XDMCP on FC5 machine using GDM setup.
Restart machine - (just to ensure changes take effect)
on client hit F10, and select FC5 machine from the chooser.

Steps to Reproduce:
1. Set up XDMCP on FC5 machine using GDM setup. 
2. Restart machine - (just to ensure changes take effect)
3. on client hit F10, and select FC5 machine from the chooser.
  
Actual results:
After selecting FC5 the screen flickers a few times and it goes back to the
client log in screen.

Attempts to connect to the FC5 machine through Xnest also show this problem. 
The Xnest windows flickers as if it starts to make a connection but then resets.

Expected results:
An FC5 login screen.

Additional info:
Comment 1 Peter Meyer 2006-04-10 21:38:43 EDT
Fedora/Redhat Team:

Please close this issue against Xorg.  The problem is with SELinux.  When
enforcement is set, it blocks the Xserver from displaying and proceeding with an
XDMCP session.

Sorry for the inconvenience.

Regards,

Peter
Comment 2 Peter Meyer 2006-04-24 21:00:53 EDT
Developers:

Sorry, I need to reopen this issue.  I am still not able to get XDMCP to serve a
remote desktop session.

Scenerio:
Client: FC4, FC3
Server: FC5

Scenerio 1
Server: setup via GDM setup.
Server: SELinux disabled.
Clients: at login screen. Hit F10 and select Server
Outcome: Client locks up.  I need to reboot the client to reset it.

Scenerio 2
Server: as above
Client: run Xnest:1 -geom 1024x768 -query server
Outcome: session shows part of a log-in screen.

Please investigate this.  This unfortunate glitch is preventing a number of us
from migrating to FC5 from FC4.

My sincere thanks!!!

Peter Meyer
Comment 3 Peter Meyer 2006-04-25 20:41:07 EDT
Further testing.  I re-built the FC5 image and can now serve back to an FC4 client. 

FC3 does not work, either for Xnest or by using the root login window.

Peter
Comment 4 Mike A. Harris 2006-05-19 09:08:19 EDT
This is a technical support problem, not a bug.  Please use the Fedora
and/or X.Org mailing lists for these type of problems.


Note You need to log in before you can comment on or make changes to this bug.