Bug 1879260 - Kernel and other packages older in 4.5.9 than 4.4.21
Summary: Kernel and other packages older in 4.5.9 than 4.4.21
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Micah Abbott
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks: 1879273
TreeView+ depends on / blocked
 
Reported: 2020-09-15 19:43 UTC by Scott Dodson
Modified: 2021-04-05 17:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1879273 (view as bug list)
Environment:
Last Closed: 2020-09-21 17:42:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:3719 0 None None None 2020-09-21 17:42:23 UTC

Description Scott Dodson 2020-09-15 19:43:47 UTC
Root cause TBD, but the RHEL package set in 4.4.21 is newer than 4.5.9.

https://releases-rhcos-art.cloud.privileged.psi.redhat.com/diff.html?arch=x86_64&first_release=44.82.202009091324-0&first_stream=releases%2Frhcos-4.4&second_release=45.82.202009040230-0&second_stream=releases%2Frhcos-4.5

This bug is mainly to provide reference for blocking the upgrade edge from 4.4.21 to 4.5.9 and will immediately go MODIFIED as this will be resolved in 4.5.10.

Comment 3 W. Trevor King 2020-09-15 19:58:28 UTC
[1] will block the edge from 4.4.21 -> 4.5.9.

[1]: https://github.com/openshift/cincinnati-graph-data/pull/436

Comment 4 Jing Zhang 2020-09-17 16:37:13 UTC
Status: ON_QA → VERIFIED

Comment 5 Jing Zhang 2020-09-17 16:41:16 UTC
[jingzhan@jingzhan cincinnati]$ CHANNEL=candidate-4.5 ./hack/available-updates.sh 4.4.21
4.4.22	quay.io/openshift-release-dev/ocp-release@sha256:508ef9f46783d2f0c546eea018fd17b9cfd5e01432c5f110b9731d7c82d7dab3	https://access.redhat.com/errata/RHBA-2020:3715
4.5.10	quay.io/openshift-release-dev/ocp-release@sha256:272a00b3dc91e1a8e45370969d4300f17bc89bc5cefb0f938f6c1b69333fe371	https://access.redhat.com/errata/RHBA-2020:3719

[jingzhan@jingzhan pkgs]$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.21    True        False         15m     Cluster version is 4.4.21
[jingzhan@jingzhan pkgs]$ oc adm upgrade
Cluster version is 4.4.21

Updates:

VERSION IMAGE
4.4.22  quay.io/openshift-release-dev/ocp-release@sha256:508ef9f46783d2f0c546eea018fd17b9cfd5e01432c5f110b9731d7c82d7dab3
4.5.10  quay.io/openshift-release-dev/ocp-release@sha256:272a00b3dc91e1a8e45370969d4300f17bc89bc5cefb0f938f6c1b69333fe371

Tests look good.

Comment 6 Micah Abbott 2020-09-17 16:42:45 UTC
Moved to VERIFIED per comment #5

Comment 8 errata-xmlrpc 2020-09-21 17:42:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719

Comment 9 W. Trevor King 2021-04-05 17:45:54 UTC
Removing UpgradeBlocker from this older bug, to remove it from the suspect queue described in [1].  If you feel like this bug still needs to be a suspect, please add keyword again.

[1]: https://github.com/openshift/enhancements/pull/475


Note You need to log in before you can comment on or make changes to this bug.