Bug 187940 - Problem switching to mls policy right after install
Problem switching to mls policy right after install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-mls (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
http://free.linux.hp.com/~mra/boot.jpg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 14:33 EDT by Matt Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 15:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Anderson 2006-04-04 14:33:05 EDT
Description of problem:
I have a desktop PC which has another OS on sda1
sda2 is configured as /boot
sda3 is LVM
inside that there is:
/dev/VolGroup00/LogVol00 as /
/dev/VolGroup00/LogVol01 as swap

Version-Release number of selected component (if applicable):
FC5 base with no updates or extras
After that I added Dan's policy repo
baseurl=ftp://people.redhat.com/dwalsh/SELinux/FC5/
and ran `yum install selinux-policy-mls`
which grabbed selinux-policy-mls-2.2.29-3.fc5 along with
selinux-policy-targeted-2.2.29-3.fc5
selinux-policy-2.2.29-3.fc5
policycoreutils-1.30.1-3.fc5
libsemanage-1.6.2-2.fc5
libsepol-1.12.4-1.fc5

How reproducible:
I've done it on a couple systems now.

How to reproduce:
Install with the defaults, "removing all linux partitions" so that it uses LVM
I didn't select any customization of packages, but I did check the software
development box
Add the repo and mls packages
use the System->Administration->'Security Level and Firewall' tool to switch to
the MLS policy.  Leave it in enforcing mode.
reboot

Actual results:
When the system boots I see the screen captured at the URL listed
I then have to cold boot the system, I can edit the grub command line to have
enforcing=0 and then the system boots, however it doesn't relabel the filesystem
at that time.

Expected results:
The system should boot and relabel the file system.

Additional info:
On the LSPP call the other day I referenced doing this on a laptop.  I have
since reproduced this on a desktop system (HP DC7600C) and gotten similar results.

Sorry the pic is a little blurry :(
Comment 2 Daniel Walsh 2006-05-09 15:26:12 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.