Bug 187941 - Can not upgrade FC4 to FC5 from the ISO's on a hard drive.
Can not upgrade FC4 to FC5 from the ISO's on a hard drive.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda-images (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 15:26 EDT by J Hoffman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 16:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J Hoffman 2006-04-04 15:26:23 EDT
Description of problem:Can not install ISO from Hard drive.


Version-Release number of selected component (if applicable):
FC5

How reproducible:Every time.


Steps to Reproduce:
1.Follow these steps: http://www.cs.cmu.edu/~colohan/docs/fedora_upgrade.html
2.Boot the system and select Hard drive.
3.Enter the path to the ISO images is not recognized and the install fails.
4.Seems to look for the images in the /tmp/hdimage directory.
5.Moved the ISO's to that directory and tried again, still fails?
  
Actual results:
Install fails

Expected results:
Install upgrades system from FC4 to FC5

Additional info:None.
Comment 1 Chris Lumens 2006-04-04 15:28:26 EDT
How does the install fail?
Comment 2 J Hoffman 2006-04-04 15:45:11 EDT
Well I key F2 and navigate to the directory and select either the DVD iso or the
CD iso.  It reports exiting abnormally. I do not know how helpful that is. It
then statrs unmounting file systems and requests a reboot.
Comment 3 J Hoffman 2006-04-05 13:59:22 EDT
Went poking aroung in thr anaconda python scripts and I see where they refer to
a /tmp/isodir.  So I created one and moved the DVD.iso there.

Now I can specify /tmp/isodir and it starts the install but fails mounting the
/dev/hda1. I ignore that, since it is already mounted, and continue.  It searchs
for installed Fedoras but does not find them.  Since it does not find them, it
assumes a new install. 

How do I tell it to upgrade?
Comment 4 Chris Lumens 2006-05-25 16:53:03 EDT
This should now be fixed in Rawhide.  The hard drive install method was broken
for installs, so that should be the cause of upgrade breaks as well.  Please
test with FC6test1 when it is released and let us know if it is still broken.

Note You need to log in before you can comment on or make changes to this bug.