Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1879425 - runc run: fix panic on failed init start
Summary: runc run: fix panic on failed init start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jindrich Novy
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
: 1868691 (view as bug list)
Depends On:
Blocks: 1186913 1845974
TreeView+ depends on / blocked
 
Reported: 2020-09-16 09:34 UTC by Jindrich Novy
Modified: 2021-01-05 20:23 UTC (History)
11 users (show)

Fixed In Version: docker-1.13.1-202.git0be3e21.el7_9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-10 17:03:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5059 0 None None None 2020-11-10 17:03:43 UTC

Description Jindrich Novy 2020-09-16 09:34:15 UTC
Description of problem:
This is continued effort to fix problem described in bug #1718441.

According to Kir Kolyshkin this issue should be addressed via https://github.com/projectatomic/runc/pull/33

Comment 2 Jindrich Novy 2020-09-16 09:40:09 UTC
Kir, the patch applies nicely with docker in the 7.9 branch. Once merged I will apply it and build new packages/file advisory for 7.9.1.

Comment 3 Kir Kolyshkin 2020-09-16 15:29:20 UTC
This is the same as https://bugzilla.redhat.com/show_bug.cgi?id=1868691, feel free to close as DUP

Comment 4 Jindrich Novy 2020-09-16 15:42:31 UTC
*** Bug 1868691 has been marked as a duplicate of this bug. ***

Comment 9 Alex Jia 2020-09-30 07:50:50 UTC
Move this bug to VERIFIED state per Comment 7 and Comment 8.

Comment 11 errata-xmlrpc 2020-11-10 17:03:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (docker bug fix and ehnancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5059


Note You need to log in before you can comment on or make changes to this bug.