Bug 1879485 - deleting application context while in git import flow loses context for creation
Summary: deleting application context while in git import flow loses context for creation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Sahil Budhwar
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 11:56 UTC by Sahil Budhwar
Modified: 2020-10-27 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6646 0 None closed Bug 1879485: fix application selector incontext for add forms 2020-11-23 19:19:16 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:31 UTC

Description Sahil Budhwar 2020-09-16 11:56:36 UTC
Steps to reproduce:

import a project and set the app to "testing"
return to the import form in the application context of "testing"
in a new browser window delete the previously imported deployment which results in the removal of the application and you will see what the screenshot shows below. The context is set to "all applications" and there is no application form fiields.
continue with the form and press create
the application is created with name "testing" even though the context was no longer presented to the user

Comment 1 Jaivardhan Kumar 2020-09-29 16:07:35 UTC
Verified on 4.6.0-0.nightly-2020-09-28-212756

Comment 4 errata-xmlrpc 2020-10-27 16:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.