Bug 1879499 - Baremetal IPI installation fails because /etc/resolv.conf is empty on master nodes
Summary: Baremetal IPI installation fails because /etc/resolv.conf is empty on master ...
Keywords:
Status: CLOSED DUPLICATE of bug 1879156
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.6.0
Assignee: Brad P. Crochet
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 12:24 UTC by Marius Cornea
Modified: 2020-09-16 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-16 14:11:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Cornea 2020-09-16 12:24:43 UTC
Description of problem:

Baremetal IPI installation fails because /etc/resolv.conf is empty on master nodes. After the master nodes get provisioned /etc/resolv.conf is empty and the nodes fail to resolve the registry hostname:

[root@openshift-master-0 core]# cat /etc/resolv.conf 
# Generated by NetworkManager
search local

[root@openshift-master-0 core]# journalctl -fl --system
-- Logs begin at Wed 2020-09-16 12:06:43 UTC. --
Sep 16 12:17:43 openshift-master-0 sh[3327]: Error: error pulling image "quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:9193c25b9d01a2b3829c28d3bc174d406dcf83e71e3b3d4da6c338fe13df3284": unable to pull quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:9193c25b9d01a2b3829c28d3bc174d406dcf83e71e3b3d4da6c338fe13df3284: unable to pull image: Error initializing source docker://quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:9193c25b9d01a2b3829c28d3bc174d406dcf83e71e3b3d4da6c338fe13df3284: (Mirrors also failed: [registry.ocp-edge1.lab.eng.tlv2.redhat.com:5000/localimages/local-release-image@sha256:9193c25b9d01a2b3829c28d3bc174d406dcf83e71e3b3d4da6c338fe13df3284: error pinging docker registry registry.ocp-edge1.lab.eng.tlv2.redhat.com:5000: Get "https://registry.ocp-edge1.lab.eng.tlv2.redhat.com:5000/v2/": dial tcp: lookup registry.ocp-edge1.lab.eng.tlv2.redhat.com on [::1]:53: read udp [::1]:55100->[::1]:53: read: connection refused]): quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:9193c25b9d01a2b3829c28d3bc174d406dcf83e71e3b3d4da6c338fe13df3284: error pinging docker registry quay.io: Get "https://quay.io/v2/": dial tcp: lookup quay.io on [::1]:53: read udp [::1]:58921->[::1]:53: read: connection refused

Also in NetworkManager journal we can notice that /etc/NetworkManager/dispatcher.d/30-resolv-prepender script failed:

Sep 16 12:07:23 openshift-master-0 NetworkManager[2917]: <warn>  [1600258043.4465] dispatcher: (11) /etc/NetworkManager/dispatcher.d/30-resolv-prepender failed (failed): Script '/etc/NetworkManager/dispatcher.d/30-resolv-prepender' exited>


Version-Release number of the following components:
4.6.0-0.nightly-2020-09-16-050052

How reproducible:
Reproducible on real bare metal setups

Steps to Reproduce:
1. Deploy OCP 4.6 bare metal IPI
2. Wait for the master nodes to get provisioned
3. SSH to the master nodes
4. Check /etc/resolv.conf

Actual results:
resolv.conf is empty and the nodes cannot reach the registry because they cannot resolve the name

Expected results:
resolv.conf include nameservers received over DHCP

Additional info:

Sharing environment credentials.

Comment 2 Brad P. Crochet 2020-09-16 14:11:35 UTC

*** This bug has been marked as a duplicate of bug 1879156 ***


Note You need to log in before you can comment on or make changes to this bug.