Bug 1879517 - Object Service Dashboard should use RGW pool prefix in queries for RGW metrics in case of external mode
Summary: Object Service Dashboard should use RGW pool prefix in queries for RGW metric...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Bipul Adhikari
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 12:52 UTC by Anmol Sachan
Modified: 2020-10-27 16:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6432 0 None closed Bug 1879517: Add support for External mode RGW queries in Data Resiliency and Capacity breakdown Cards 2020-12-23 06:23:05 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:31 UTC

Description Anmol Sachan 2020-09-16 12:52:24 UTC
Description of problem: Currently the RGW capacity usage and data resiliency queries are same for both internal and external mode. The queries should use the RGW pool prefix supplied with external cluster secret in case of external mode. 


Version-Release number of selected component (if applicable):


How reproducible: 100 %


Steps to Reproduce:
1.Create an internal mode OCS cluster and deploy object storage workload on it. Workload should be of both MCG and RGW.
2.Create an external mode cluster and deploy object storage workload on it. Workload should be of both MCG and RGW.

Actual results: In case of external mode RGW pool prefix is not considered and gives no result in metrics.


Expected results: In case of external mode RGW pool prefix should be considered.


Additional info:

Comment 5 errata-xmlrpc 2020-10-27 16:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.