Bug 1879522 - [Descheduler] - The minKubeVersion should be 1.19
Summary: [Descheduler] - The minKubeVersion should be 1.19
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Jan Chaloupka
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 13:04 UTC by RamaKasturi
Modified: 2020-10-27 16:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-descheduler-operator pull 133 0 None open bug 1879522: 4.6 manifests: bump minKubeVersion to 1.19.0 2020-09-16 13:30:28 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:31 UTC

Description RamaKasturi 2020-09-16 13:04:59 UTC
Description of problem:
[ramakasturinarra@dhcp35-60 openshift-client-linux-4.6.0-0.nightly-2020-09-16-000734]$ oc get csv clusterkubedescheduleroperator.4.6.0-202009152100.p0 -o json | jq '.spec.minKubeVersion'
"1.18.0"


Version-Release number of selected component (if applicable):
[ramakasturinarra@dhcp35-60 openshift-client-linux-4.6.0-0.nightly-2020-09-16-000734]$ oc get csv clusterkubedescheduleroperator.4.6.0-202009152100.p0 -o json | jq '.spec.minKubeVersion'
"1.18.0"


How reproducible:
Always

Steps to Reproduce:
1. Install latest 4.6 cluster
2. Run command oc get csv clusterkubedescheduleroperator.4.6.0-202009152100.p0 -o json | jq '.spec.minKubeVersion'
3.

Actual results:
[ramakasturinarra@dhcp35-60 openshift-client-linux-4.6.0-0.nightly-2020-09-16-000734]$ oc get csv clusterkubedescheduleroperator.4.6.0-202009152100.p0 -o json | jq '.spec.minKubeVersion'
"1.18.0"


Expected results:
should show 1.19 or 1.19.2

Additional info:

Comment 2 RamaKasturi 2020-09-17 09:19:33 UTC
Moving the bug to verified state as i see that the minkubeversion has been changed to 1.19.0.

[ramakasturinarra@dhcp35-60 verification-tests]$ oc get csv
NAME                                                   DISPLAY                     VERSION                 REPLACES   PHASE
clusterkubedescheduleroperator.4.6.0-202009170139.p0   Kube Descheduler Operator   4.6.0-202009170139.p0              Succeeded
[ramakasturinarra@dhcp35-60 verification-tests]$ oc get csv clusterkubedescheduleroperator.4.6.0-202009170139.p0 -o json | jq '.spec.minKubeVersion'
"1.19.0"

Comment 5 errata-xmlrpc 2020-10-27 16:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.