Bug 1879554 - buildah images missing for Power and z
Summary: buildah images missing for Power and z
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Multi-Arch
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Rafael Fonseca
QA Contact: Deep Mistry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 14:07 UTC by Rafael Fonseca
Modified: 2020-10-27 16:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25514 0 None closed Bug 1879554: Use multi-arch registry for buildah images 2020-11-25 21:11:16 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:31 UTC

Description Rafael Fonseca 2020-09-16 14:07:31 UTC
Description of problem: One of the OCP e2e tests fail with `exec error` because quay.io/buildah/stable:latest is not available for multi-arch.


Version-Release number of selected component (if applicable): 4.6+


How reproducible: always


Steps to Reproduce: OCP-4.6 e2e tests


Actual results: "[sig-builds][Feature:Builds] custom build with buildah  being created from new-build should complete build with custom builder image [Suite:openshift/conformance/parallel]" fails


Expected results: The correct image for the architecture is used


Additional info: upstream issue https://github.com/containers/buildah/issues/2002

Comment 1 Yaakov Selkowitz 2020-09-16 14:52:43 UTC
Could registry.redhat.io/rhel8/buildah:latest be used instead?

Comment 3 Jeremy Poulin 2020-09-28 15:28:30 UTC
@Christy - can you check that these tests are now passing https://github.com/openshift/release/blob/master/ci-operator/jobs/openshift/release/openshift-release-release-4.6-periodics.yaml#L577-L586

Comment 4 Christy Norman 2020-09-30 22:49:58 UTC
Indeed. I made myself a task for this and I'll try to get it done next week.

Comment 5 Christy Norman 2020-10-06 16:15:18 UTC
Yep, this runs and builds things now. Someone one the team will open a PR to remove it from the skip list. Should we do it for Power and z?

Comment 6 Rafael Fonseca 2020-10-06 16:23:51 UTC
It won't work on Z yet until https://github.com/openshift/origin/pull/25558 merges.

Comment 7 Rafael Fonseca 2020-10-06 16:24:52 UTC
Of course the problem with Z is related to Centos, not buildah so it shouldn't stop this bug from being closed.

Comment 10 errata-xmlrpc 2020-10-27 16:41:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.