Bug 1879620 - No MachineSet creation or modification documentation for vsphere
Summary: No MachineSet creation or modification documentation for vsphere
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Cody Hoag
QA Contact: sunzhaohua
Vikram Goyal
URL:
Whiteboard:
: 1878981 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 16:17 UTC by Sudarshan Chaudhari
Modified: 2020-11-09 19:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-09 19:46:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 5307621 0 None None None 2020-11-05 18:50:26 UTC

Description Sudarshan Chaudhari 2020-09-16 16:17:21 UTC
Document URL: 
Access: https://docs.openshift.com/container-platform/4.6/ -> "Machine Management"

Something similar to: https://docs.openshift.com/container-platform/4.6/machine_management/creating_machinesets/creating-machineset-aws.html

Section Number and Name: 
Creating and modifying the MachineSet for VMWare.

Describe the issue: 
It has been a while since we have the OCP IPI for Vsphere which uses MachineSet for creating and managing the Machines for OCP. 

The Documentation is lacking the details for Configuring the MachineSet for Vsphere

Suggestions for improvement: 

Need details on What all configs are there and what all customizations that we can do to MachineSets, such as adding "spec.template.spec.prodiverSpec.values.workspace.resourcePool" in workerMachineSet so that the vms are created from within a specific resource pool. 

Additional information: 
Something similar to what was requested at https://bugzilla.redhat.com/show_bug.cgi?id=1747949
See details to pick information for:
https://github.com/openshift/machine-api-operator/blob/2b0f59dd296a1f2eab8c6088a6b9225a0d17d55b/pkg/controller/vsphere/reconciler.go#L588-L592
https://github.com/openshift/machine-api-operator/blob/a682acd6c162c8caf1de10a6006586d2909c1a95/pkg/controller/vsphere/reconciler_test.go#L249-L267

Comment 2 sunzhaohua 2020-09-23 01:24:26 UTC
4.5 related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1878981

Comment 3 Cody Hoag 2020-11-05 18:45:26 UTC
@zhsun can you review this PR for creating a vSphere MachineSet?:

https://github.com/openshift/openshift-docs/pull/27119

Thanks!

Comment 4 Cody Hoag 2020-11-05 18:50:27 UTC
*** Bug 1878981 has been marked as a duplicate of this bug. ***

Comment 5 Cody Hoag 2020-11-09 14:48:44 UTC
QE verified in the PR.

Comment 6 Cody Hoag 2020-11-09 16:19:43 UTC
This has been merged. I'll provide the live links when they're available.


Note You need to log in before you can comment on or make changes to this bug.