Bug 1879623 - Acronym in the object badge for CR instance should expand to 4 chars as other objects
Summary: Acronym in the object badge for CR instance should expand to 4 chars as other...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 16:23 UTC by tony.wu
Modified: 2020-10-27 16:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-09-16-062819 Cluster ID: 34585dba-2586-4685-8464-8b3a559bcb79 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36
Last Closed: 2020-10-27 16:41:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
badge-acronym-collide (150.18 KB, image/png)
2020-09-16 16:23 UTC, tony.wu
no flags Details
Verification screenshot (61.08 KB, image/png)
2020-09-21 09:35 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6654 0 None closed Bug 1879623: Increase max kind abbrev to 4 chars 2020-09-21 01:26:31 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:59 UTC

Description tony.wu 2020-09-16 16:23:29 UTC
Created attachment 1715107 [details]
badge-acronym-collide

Description of problem:
Currently the console only takes the first 3 uppercase characters from the CR Kind for the badge.

However, for some CRD with longer `spec.name.kind`, they often get the same first 3 uppercase characters in their badges. 

It's noticed console does have some badges use 4 chars in the “Search” page dropdown menu, e.g. `ConsoleExternalLogLink` use `CELL`.

Let's apply this also to CR instances as well.


Version-Release number of selected component (if applicable):
OCP 4.6


How reproducible:
100%


Steps to Reproduce:
1. Install "ServiceMesh" from 'OperatorHub' page
2. Go to 'Search' page and find "ServiceMeshMember" and "ServiceMeshMemberRoll" resource types


Actual results:
"ServiceMeshMember" and "ServiceMeshMemberRoll" both use "SMM" in the badge.


Expected results:
"ServiceMeshMember" use "SMM", and "ServiceMeshMemberRoll" use "SMMR" in the badge


Additional info:

Comment 2 XiaochuanWang 2020-09-21 09:35:38 UTC
Created attachment 1715507 [details]
Verification screenshot

Comment 3 XiaochuanWang 2020-09-21 09:36:53 UTC
Refer to the verification screenshot, this could be Verified on 4.6.0-0.nightly-2020-09-20-184226

Comment 7 errata-xmlrpc 2020-10-27 16:41:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.