Bug 1879639 - operator-sdk bundle validate fails when the csv name contains invalid semver
Summary: operator-sdk bundle validate fails when the csv name contains invalid semver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Operator SDK
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Joe Lanford
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 17:25 UTC by lgallett
Modified: 2020-10-27 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ocp-release-operator-sdk pull 75 0 None closed V0.19.4 merge 2020-12-03 01:57:23 UTC
Github operator-framework operator-sdk pull 3892 0 None closed *: release v0.19.4 2020-12-03 06:39:58 UTC
Github operator-framework operator-sdk pull 3901 0 None closed *: release v1.0.1 2020-12-03 06:40:22 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:59 UTC

Description lgallett 2020-09-16 17:25:11 UTC
Description of problem:

operator-sdk bundle validate fails when the csv name contains invalid semver


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. create a csv with name.v<invalid.semver>

Actual results:

validation fails

Expected results:

validation should succeed as OLM is agnostic to the name of the csv

Additional info:

Comment 1 Joe Lanford 2020-09-17 16:25:05 UTC
This is merged in the v0.19.x branch, v1.0.x branch, and master branch.

I am in the process of releasing v0.19.4 and v1.0.1, which will include a fix for this bug.

Comment 3 Jesus M. Rodriguez 2020-09-18 16:24:53 UTC
Moved to modified as v0.19.4 release PR merged downstream.

Comment 8 errata-xmlrpc 2020-10-27 16:41:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.