Bug 1879640 - api validation fails when csv name contains invalid semver
Summary: api validation fails when csv name contains invalid semver
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.7.0
Assignee: lgallett
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-16 17:26 UTC by lgallett
Modified: 2020-11-03 18:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-03 18:27:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description lgallett 2020-09-16 17:26:39 UTC
Description of problem:

api bundle validation fails when the csv name contains invalid semver


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. create a csv with name.v<invalid.semver>

Actual results:

validation fails

Expected results:

validation should succeed as OLM is agnostic to the name of the csv

Additional info:

Comment 4 Nick Hale 2020-10-19 14:10:43 UTC
Lance,

This BZ is pretty vague. As far as I was aware, any validation that OLM does IS agnostic of the CSV naming. Can you be more specific about which validation fails? Is this in SDK or the API repo?

Thanks

Also, since no one has picked this up and we're in the last week of the sprint, I'm moving this out to the next sprint.

Comment 6 lgallett 2020-11-03 18:27:00 UTC
Closing as this has already been fixed here https://github.com/operator-framework/api/pull/63 and has been added to the sdk here https://github.com/operator-framework/operator-sdk/pull/3886


Note You need to log in before you can comment on or make changes to this bug.