Bug 1879794 - Namespace column heading is missing but its value is shown on Pods list page
Summary: Namespace column heading is missing but its value is shown on Pods list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 03:37 UTC by Yadan Pei
Modified: 2020-10-27 16:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Namespace column is missing on pods list page (172.86 KB, image/png)
2020-09-17 03:38 UTC, Yadan Pei
no flags Details
when project is selected namepspace data is not shown (234.11 KB, image/png)
2020-09-25 02:32 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6713 0 None closed Bug 1879794: Fix to remove namespace cell data when project is selected 2020-10-26 18:55:39 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:59 UTC

Description Yadan Pei 2020-09-17 03:37:35 UTC
Description of problem:
on Pods list page, Namespace column header is missing 

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-09-16-175801

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user goes to Workloads -> Pods list page
2. check pods list table columns
3.

Actual results:
2. There are only 8 columns and Namespace column is missing

Expected results:
2. Default Pod columns should be 9 columns and Namespace should be shown in the table as well

Additional info:

Comment 1 Yadan Pei 2020-09-17 03:38:19 UTC
Created attachment 1715154 [details]
Namespace column is missing on pods list page

Comment 2 Yadan Pei 2020-09-17 03:41:01 UTC
To be clear, the issue is reproduced when:

User(either cluster-admin user or normal user) is on Pods list page and a project is selected

Comment 3 Yadan Pei 2020-09-17 03:41:59 UTC
When a project is selected, maybe there is no need to show `Namespace` column and its data

Comment 4 Jakub Hadvig 2020-09-17 10:11:06 UTC
@Joe could you please re-evaluate if this is something critical and should go into 4.6 ?

Comment 6 Yadan Pei 2020-09-25 02:32:18 UTC
Created attachment 1716473 [details]
when project is selected namepspace data is not shown

When a project is selected, Namespace data is not shown in the pods list table

Verified on 4.6.0-0.nightly-2020-09-24-211545

Comment 9 errata-xmlrpc 2020-10-27 16:41:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.