Bug 1879939 - [RFE] Satellite-maintain should set read-only attribute, for important Satellite and Capsule configuration files
Summary: [RFE] Satellite-maintain should set read-only attribute, for important Satell...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 12:00 UTC by Satyajit Das
Modified: 2020-09-29 08:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-22 13:09:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Satyajit Das 2020-09-17 12:00:36 UTC
Description of problem:

[RFE] Satellite-maintain should set read-only attribute, for important Satellite and Capsule configuration file

Version-Release number of selected component (if applicable):

Red Hat Satellite/Capsule 6.x

How reproducible:

Always.

Situation:-

Satellite is based on puppet architecture, however a lot of customer uses their own config mgmt tools to manage configuration in their environment(ex. External puppet,Chef) and sometime just to test few settings, customer manually/using external configuration mgmt tools modify these important configuration files (Ex. satellite-answers.yaml/satellite.yaml), which does not impact the running satellite server, however during upgrade/update the  Satellite-maintain/satellite-installer fails with sytax error and sometime it is difficult to recover as customer's are not fully aware of what changes were done and by whom.

To avoid such scenario, I have reported this RFE to address the issue. Where during installation, the satellite-installer will set read only attributes for important configuration file for existing satellite-server deployment, during upgrade the satellite-maintain should set the file-system attribute. Just like we have recently implemented the version lock feature for package update in satelite

For example we can use the chattr command to set and unset the attribute as an when required by the satellite-maintain.


Additional info:

Comment 2 Sean O'Keeffe 2020-09-22 13:09:14 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support.
Thank you Sean


Note You need to log in before you can comment on or make changes to this bug.