Bug 1879940 - Non admin users can't load the create vm wizard
Summary: Non admin users can't load the create vm wizard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 12:01 UTC by Yaacov Zamir
Modified: 2020-10-27 16:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6666 0 None closed Bug 1879940: Non admin users should load the create vm wizard 2020-09-22 03:00:58 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:42:10 UTC

Description Yaacov Zamir 2020-09-17 12:01:51 UTC
Description of problem:
Non admin users can't load the create vm wizard

Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1. log in as a none admin user
2. go to the virtualization tab
3. open the create vm wizard

Actual results:
the wizard fields of os, flavor and workload will be stuck in loading state.

Expected results:
the wizard should load (without the base image functionality)

Additional info:
user should be notified when running the wizard without permissions that base images functionality will not be available for them.

Comment 4 errata-xmlrpc 2020-10-27 16:41:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.