Bug 187995 - autofs not starting with multi option using ldap maps
autofs not starting with multi option using ldap maps
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 05:10 EDT by hbabaria
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 15:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hbabaria 2006-04-05 05:10:05 EDT
Description of problem:
We want to migrate the auto.master file from NIS to use ldap based maps.

/etc/auto.master 
/home  multi file /etc/auto.home -- yp auto.home-test   rw,intr,nosuid,
rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600

Is the multi option supported with ldap based map ? 

If yes please provide the exact systax to use .

Version-Release number of selected component (if applicable):
autofs-4.1.3-154

This entry works fine.

/home  ldap:nisMapName=auto.home-test,dc=test,dc=com         rw,intr,nosuid,
rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600

With this entry in /etc/auto.master autofs fails to start.

/home multi file /etc/auto.home ldap:nisMapName=auto.home-test,dc=test,dc=com    
     rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600
Comment 1 Jeffrey Moyer 2006-04-17 18:40:34 EDT
You need to separate each map name in a multi-map entry by a "--".

Try:

/home multi file /etc/auto.home -- ldap:nisMapName=auto.home-test,dc=test,dc=com    
     rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600
Comment 2 hbabaria 2006-04-18 05:39:16 EDT
Does not work adding "--" in  /etc/auto.master 

# service autofs start
Starting automount:
failed to load map: "/usr/sbin/automount --timeout=60 /home multi file
/etc/auto.home -- ldap:nisMapName=auto.home-test,dc=test,dc=com
rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600"
Comment 3 Jeffrey Moyer 2006-04-18 09:47:31 EDT
what does service autofs status show?  and are there any log messages at startup?
You may need to change the above to:

home multi file:/etc/auto.home -- ldap:nisMapName=auto.home-test,dc=test,dc=co
-rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600

Note the : between file and /etc/auto.home.
Comment 4 hbabaria 2006-04-19 03:52:14 EDT
# service autofs status
Configured Mount Points:
------------------------
/usr/sbin/automount --timeout=60 /home multi file:/etc/auto.home --
ldap:nisMapName=auto.home-test,dc=test,dc=com
rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600

Active Mount Points:
--------------------
<DOES NOT SHOW ANYTHING>

[root@ap6002ldap root]# service autofs start
Starting automount:
failed to load map: "/usr/sbin/automount --timeout=60 /home multi
file:/etc/auto.home -- ldap:nisMapName=auto.home-test,dc=test,dc=com
rw,intr,nosuid,rsize=16384,wsize=16384,tcp[WARNING]3,timeo=600"


In logs the following messages is observed.

Apr 19 00:54:20 ap6002test automount[32274]: lookup(multi): cannot open lookup
module file:/etc/auto.home (/usr/lib/autofs/lookup_file:/etc/auto.home.so:
cannot open shared object file: No such file or directory)
Comment 5 hbabaria 2006-04-19 06:17:12 EDT
Also ,

Following entry works fine in NIS .

#cat /etc/auto.master
+auto_master-test

How do we migrate the same to use ldap ? 

the automap file auto_master-test is uploaded in ldap.

dn: nisMapName=auto_master-test,dc=test,dc=com

Can you please provide the exact syntax to use.

Thanks
Comment 6 Jeffrey Moyer 2006-04-26 15:56:13 EDT
It seems I pointed you in the wrong direction, here.  The multi map entry should
work if you use the following syntax:

home multi file /etc/auto.home -- ldap nisMapName=auto.home-test,dc=test,dc=com
-rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600

Note that you need to specify the mount options per map.  So, the above entry
will only apply the provided mount options to the ldap map entries.  To apply
them to both, you would use the following:

home multi file /etc/auto.home
-rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600 -- ldap
nisMapName=auto.home-test,dc=test,dc=com
-rw,intr,nosuid,rsize=16384,wsize=16384,tcp,nfsvers=3,timeo=600

For further information on configuring your maps, please refer to the following URL:

  http://www.ldapguru.com/modules/newbb/viewtopic.php?topic_id=2029&forum=6

If you can't find enough information there, I'd urge you to either contact Red
Hat support or post your questions to the autofs mailing list.

I'm closing this bug as NOTABUG, since it was a configuration error.
Comment 7 hbabaria 2006-05-03 05:10:06 EDT
The problem is not resolved with the solution given or by referring to the URL 
as mentioned in the last post .As suggested will post the details to the autofs 
mailing list.

Thanks

Note You need to log in before you can comment on or make changes to this bug.