Bug 1879994 - v2v-conversion-image is not updated during CNV upgrade from 2.4.0 to 2.4.1
Summary: v2v-conversion-image is not updated during CNV upgrade from 2.4.0 to 2.4.1
Keywords:
Status: CLOSED DUPLICATE of bug 1879993
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: V2V
Version: 2.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Brett Thurber
QA Contact: Daniel Gur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 14:06 UTC by Fabien Dupont
Modified: 2020-09-25 08:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-22 18:40:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Fabien Dupont 2020-09-17 14:06:26 UTC
Description of problem:

When upgrading CNV from 2.4.0 to 2.4.1, the "v2v-conversion-image" attribute of the "v2v-vmware" config map is not updated with the SHA256 signature of the image for 2.4.1. The consequence is that the import will still use the 2.4.0 image.


To find what the SHA256 signature of an image is, one can use the following commands:

$ podman login registry.redhat.io
$ podman pull registry.redhat.io/container-native-virtualization/kubevirt-v2v-conversion:v2.4.0
$ podman inspect registry.redhat.io/container-native-virtualization/kubevirt-v2v-conversion:v2.4.0 | jq '.[]["Digest"]'

The SHA256 in "v2v-conversion-image" was "e3056e80f0aecf186bfac6504f23aa58d33120d0ba9646a816bd4f341b030cae", while should have been "f160e205506908b7145a1414158721c9c01ffdcf12f55ebe38d8f22432a92d08".


Version-Release number of selected component: 2.4.0 and 2.4.1

Comment 1 Filip Krepinsky 2020-09-21 08:42:49 UTC
this should be handled by upgrade of HCO and not CNV. Also the UI just reads the value from config map and does not manage it. Moving..

Comment 3 Brett Thurber 2020-09-22 18:40:06 UTC

*** This bug has been marked as a duplicate of bug 1879993 ***


Note You need to log in before you can comment on or make changes to this bug.