Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1880004 - Submit button doesn't get disabled on import forms while action is in progress
Summary: Submit button doesn't get disabled on import forms while action is in progress
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Rohit Rai
QA Contact: Debsmita Santra
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-17 14:18 UTC by Rohit Rai
Modified: 2020-10-27 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:41:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6669 0 None closed Bug 1880004: Disable submit button of import forms while submitting 2020-09-29 15:00:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:42:10 UTC

Description Rohit Rai 2020-09-17 14:18:05 UTC
Steps to Reproduce:
1. Go to +Add -> From Git
2. Fill the required fields.
3. Click on 'Create' button

Actual Results:
It stays on the same form page and clicking again on 'Create' button gives error message

Expected Results:
`Submit/Create` button should be disabled while showing a loading animation when user clicks on it

How reproducible:
Intermittent

Additional Info:
Build: 4.5.0-0.ci-2020-05-18-204038
Browser: Google Chrome Version 81.0.4044.129

Please have a look at the video shared.

Comment 3 Debsmita Santra 2020-09-22 15:52:56 UTC
verified on build 4.6.0-0.nightly-2020-09-22-073212

Comment 6 errata-xmlrpc 2020-10-27 16:41:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.