This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188030 - hal detects non raid partition as raid.
hal detects non raid partition as raid.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 10:21 EDT by drago01
Modified: 2013-03-05 22:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-09 06:04:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lshal output (107.29 KB, text/plain)
2006-04-05 10:21 EDT, drago01
no flags Details

  None (edit)
Description drago01 2006-04-05 10:21:19 EDT
Description of problem:

hal detects my partition (/dev/sdb5) which is ntfs as raid.

Version-Release number of selected component (if applicable):
hal-0.5.7-3

How reproducible:

always

Steps to Reproduce:
1. look at lshal output (or use hal-device-manager)
2. notice a raid volume that is a ntfs one
3.
  
Actual results:

wrong partition type detection

Expected results:

correct partition type detection.
Additional info:
fdisk -l output:
Disk /dev/hda: 40.0 GB, 40016019968 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        4864    39070048+   b  W95 FAT32

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       13054   104856223+   7  HPFS/NTFS
/dev/sda2   *       13055       22192    73400985    7  HPFS/NTFS
/dev/sda3           22193       22205      104422+  83  Linux
/dev/sda4           22206       30401    65834370    f  W95 Ext'd (LBA)
/dev/sda5           30304       30401      787153+  82  Linux swap / Solaris
/dev/sda6           22206       30303    65047122   fd  Linux raid autodetect

Partition table entries are not in disk order

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        8159    65537136    7  HPFS/NTFS
/dev/sdb2            8160       30401   178658865    f  W95 Ext'd (LBA)
/dev/sdb5            8160       20907   102398247    7  HPFS/NTFS
/dev/sdb6           20908       29006    65055186   fd  Linux raid autodetect
/dev/sdb7   *       29007       30401    11205306    7  HPFS/NTFS

Disk /dev/md0: 133.2 GB, 133224464384 bytes
2 heads, 4 sectors/track, 32525504 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md0 doesn't contain a valid partition table
Comment 1 drago01 2006-04-05 10:21:19 EDT
Created attachment 127354 [details]
lshal output
Comment 2 John (J5) Palmieri 2006-04-17 17:02:54 EDT
David, any idea?
Comment 3 David Zeuthen 2006-04-17 17:10:43 EDT
Most probably there are traces left from old uses of the disk. Did you use to
have a raid member on this partition? What tool did you use to format it as ntfs?

This is a pretty frequent kind of bug because the tools for formatting file
systems don't clear out important sectors areas of the block device where udev
and friends look for file system signatures.
Comment 4 drago01 2006-07-08 02:01:59 EDT
the bug seems to have been fixed itself; the partition is detected right after I
checked now.
But I don't know what has fixed it I am using hal-0.5.7-3.fc5.2 and
kernel-2.6.17-1.2145_FC5.
Comment 5 drago01 2007-02-09 06:04:45 EST
its fixed so it should be closed

Note You need to log in before you can comment on or make changes to this bug.