Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1880307 - [release 4.5] console-operator: Fix bug in reflector not recovering from "Too large resource version"
Summary: [release 4.5] console-operator: Fix bug in reflector not recovering from "Too...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1880369
Blocks: 1879901
TreeView+ depends on / blocked
 
Reported: 2020-09-18 09:29 UTC by Lukasz Szaszkiewicz
Modified: 2020-10-19 14:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-19 14:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 470 0 None closed Bug 1880307: Bump k8s vendors to 1.18.9. to fix bug in reflector not recovering from 'Too large resource version' 2021-01-21 04:27:40 UTC
Github openshift console-operator pull 471 0 None closed Bug 1880307: Fix inconsistent vendoring in vendor/modules.txt 2021-01-21 04:27:40 UTC
Red Hat Product Errata RHBA-2020:4228 0 None None None 2020-10-19 14:54:48 UTC

Description Lukasz Szaszkiewicz 2020-09-18 09:29:09 UTC
A recent fix in the reflector/informer https://github.com/kubernetes/kubernetes/pull/92688 prevents components/operators from entering a hotloop and stuck.

There are already reported cases that have run into that issue and were stuck for hours or even days. For example https://bugzilla.redhat.com/show_bug.cgi?id=1877346.

The root cause of the issue is the fact that a watch cache is initialized from the global revision (etcd) and might stay on it for an undefined period (if no changes were (add, modify) made). 
That means that the watch cache across server instances may be out of sync. 
That might lead to a situation in which a client gets a resource version from a server that has observed a newer rv, disconnect (due to a network error) from it, and reconnect to a server that is behind, resulting in “Too large resource version“ errors.

More details in https://github.com/kubernetes/kubernetes/issues/91073 and https://github.com/kubernetes/enhancements/tree/master/keps/sig-api-machinery/1904-efficient-watch-resumption


It looks like the issue only affects 1.18. According to https://github.com/kubernetes/kubernetes/issues/91073#issuecomment-652251669 the issue was first introduced in that version by changes done to the reflector. 
The fix is already present in 1.19.


Please make sure that console-operator is using a client-go that includes https://github.com/kubernetes/kubernetes/pull/92688 if not please use this BZ and file a PR.
In case you are using a framework to build your operator make sure it uses the right version of the client-go library.

Comment 4 Yadan Pei 2020-10-12 03:17:22 UTC
1. disconnected a node from network for a few minutes
# oc debug node/qe-yapei45-xxxx-master-0.c.openshift-qe.internal
Starting pod/qe-yapei45-xxxx-master-0copenshift-qeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.0.4
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host
sh-4.4# cd /root
sh-4.4# ls
test.sh
sh-4.4# bash test.sh &
[1] 1564316

2. After connection recovered, reconnected to node, check if the such error messages in bug can be found, 
kubelet logs, 
$ oc debug node/ip-xx-0-xxx-242.us-east-2.compute.internal
sh-4.4# journalctl -b -u kubelet |  grep -i 'Too large resource version'

No longer see the such error messages in kubelet logs.


3. I think for each component, we should check component operator logs, then I checked console-operator logs, also didn't see 'Too large resource version' errors
# oc logs console-operator-5ffd57b9b-8t294 -n openshift-console-operator | grep -i 'too large'   // nothing returns

Moving to VERIFIED on 4.5.0-0.nightly-2020-10-10-013307


Do let me know if my steps are wrong. Thanks

Comment 7 errata-xmlrpc 2020-10-19 14:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4228


Note You need to log in before you can comment on or make changes to this bug.