Bug 188031 - Wrong location for app-defaults in xterm man page
Wrong location for app-defaults in xterm man page
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 10:21 EDT by David A. De Graaf
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 11:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for minstall.sh and man-page to fix man-page paths for Modular X11 (1.61 KB, patch)
2006-04-13 16:44 EDT, Jason Vas Dias
no flags Details | Diff
Patch for minstall.sh and man-page to fix man-page paths for Un-Modular X11 (335 bytes, patch)
2006-04-13 16:44 EDT, Jason Vas Dias
no flags Details | Diff

  None (edit)
Description David A. De Graaf 2006-04-05 10:21:35 EDT
Description of problem:
xterm man page has errors

Version-Release number of selected component (if applicable):xterm-211-1.FC5


How reproducible:Every time I do 'man xterm' it comes out the same.    :-)


Steps to Reproduce:
1. app-defaults dir is relocated to /usr/share/X11/app-defaults, but man page
still says the old location - /usr/lib/X11/app-defaults
2. 
3.
  
Actual results:


Expected results:


Additional info:  Both XTerm and XTerm-color are listed incorrectly.
Comment 1 Thomas E. Dickey 2006-04-05 12:30:54 EDT
That's something I overlooked in scripting the install for manpage.
Comment 2 Jason Vas Dias 2006-04-13 16:39:43 EDT
This bug is now fixed with xterm-212-1.FC{4,5,6} - the paths in the xterm 
man-page are now all correct.


Comment 3 Jason Vas Dias 2006-04-13 16:44:06 EDT
Created attachment 127727 [details]
Patch for minstall.sh and man-page to fix man-page paths for Modular X11

For the benefit of the upstream maintainer :

It turns out that the man-page paths  come from the "APP_DIR" environment
variable during the build, and this has to be set to the app-defaults 
directory location, prefixed by the "$RPM_BUILD_ROOT" - so paths were
getting into the man page prefixed by $RPM_BUILD_DIR :-( 

I fixed this by applying this patch to the 'minstall.sh' script that generates
the man-page for FC-5 / Modular X11 - FC-4 (Un-Modular X11) patch follows.
Comment 4 Jason Vas Dias 2006-04-13 16:44:49 EDT
Created attachment 127728 [details]
Patch for minstall.sh and man-page to fix man-page paths for Un-Modular X11
Comment 5 Thomas E. Dickey 2006-04-13 19:01:36 EDT
But if you added the configure option
   --with-app-defaults=$apploaddir
that should work.
Comment 6 Fedora Update System 2006-04-17 11:40:17 EDT
xterm-212-1.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Fedora Update System 2006-05-03 14:50:34 EDT
xterm-212-1.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Fedora Update System 2006-05-03 14:51:38 EDT
xterm-212-1.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.