Bug 1880316 - Revert workaround for osd_objectstore introduced with BZ#1733577
Summary: Revert workaround for osd_objectstore introduced with BZ#1733577
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z5
: ---
Assignee: ndeevy
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On: 1875777
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 09:45 UTC by Giulio Fidente
Modified: 2021-03-18 13:27 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-18 13:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Giulio Fidente 2020-09-18 09:45:54 UTC
Due to https://bugzilla.redhat.com/show_bug.cgi?id=1875777 , we need to implement a temporary workaround in the procedure which performs migration of Ceph OSDs from filestore to bluestore.

Specifically, for those customers which didn't set "osd_objectstore" explicitly when deploying OSP13/RHCS3 and which, after the upgrade to RHCS4, want to migrate the OSDs from filestore to bluestore, there are some additional steps to perform.

These should roughly be:

1) create an environment file (eg. pretend_filestore.yaml) with the following:

parameter_defaults:
  CephAnsibleExtraConfig:
    osd_objectstore: filestore

or edit in any pre-existing custom environment file applying specific variables via CephAnsibleExtraConfig, appending `osd_objectstore: filestore` into it

2) perform a stack update using "overcloud deploy --stack-only -e pretend_filestore.yaml" (append also with -e any environment file which was passed on converge step during ffu)

3) proceed with the filestore to bluestore migration using the existing documentation

Comment 1 ndeevy 2020-10-01 10:36:41 UTC
Closing this doc BZ because the workaround will be documented as part of a release note connected to the following known issue BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1733577

Comment 3 ndeevy 2021-01-25 11:19:39 UTC
Hi Giulio, thanks for this BZ. That's good news that there will be a fix. No, I can track with this BZ. Just to clarify, the fix will need to be in the 16.1.5 and later docs?
Thanks again,
Naomi

Comment 4 Giulio Fidente 2021-01-25 12:38:56 UTC
(In reply to ndeevy from comment #3)
> Hi Giulio, thanks for this BZ. That's good news that there will be a fix.
> No, I can track with this BZ. Just to clarify, the fix will need to be in
> the 16.1.5 and later docs?

yes, this is because the fix in ceph-ansible (currently expected for release with the 4.1z2 update, in march) will be effective for every OSP16 minor released *after* that date

Comment 6 ndeevy 2021-02-19 13:45:48 UTC
Hi Giulio,
Yes we can target for 16.1.4. Just to clarify the changes needed now:

1. Remove the warning from FFU [1] that says:

Note
    There is currently a known issue that causes the migration of Ceph OSDs from FileStore to BlueStore to fail in use cases where the osd_objectstore parameter is not set or is set to bluestore in deployment templates. For more information, see BZ#1733577 in the Red Hat OpenStack Platform 16.1 Release Notes. 

2. And the Known Issue that talks about BZ#1733577 in the release notes should not be reproduced for the 16.1.4 Notes.

Is that correct?


[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.1/html-single/framework_for_upgrades_13_to_16.1/index#OSD-migration-from-filestore-to-bluestore

[2] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.1/html-single/release_notes/index#known_issues_4


Thanks,
-Naomi

Comment 7 Giulio Fidente 2021-02-19 17:34:31 UTC
(In reply to ndeevy from comment #6)
> Hi Giulio,
> Yes we can target for 16.1.4. Just to clarify the changes needed now:
> 
> 1. Remove the warning from FFU [1] that says:
> 
> Note
>     There is currently a known issue that causes the migration of Ceph OSDs
> from FileStore to BlueStore to fail in use cases where the osd_objectstore
> parameter is not set or is set to bluestore in deployment templates. For
> more information, see BZ#1733577 in the Red Hat OpenStack Platform 16.1
> Release Notes. 

correct, remove the above note in the docs [1] and ...
 
> 2. And the Known Issue that talks about BZ#1733577 in the release notes
> should not be reproduced for the 16.1.4 Notes.
> 
> Is that correct?

yes correct, remove the known issue from BZ#1733577 in the release notes
 
> [1]
> https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.
> 1/html-single/framework_for_upgrades_13_to_16.1/index#OSD-migration-from-
> filestore-to-bluestore
> 
> [2]
> https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.
> 1/html-single/release_notes/index#known_issues_4


Note You need to log in before you can comment on or make changes to this bug.