Bug 1880329 - [release 4.6] machine-api-operator: Fix bug in reflector not recovering from "Too large resource version"
Summary: [release 4.6] machine-api-operator: Fix bug in reflector not recovering from ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Alberto
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks: 1880343 1880369
TreeView+ depends on / blocked
 
Reported: 2020-09-18 10:02 UTC by Lukasz Szaszkiewicz
Modified: 2020-10-27 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1880343 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:42:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:42:45 UTC

Description Lukasz Szaszkiewicz 2020-09-18 10:02:37 UTC
A recent fix in the reflector/informer https://github.com/kubernetes/kubernetes/pull/92688 prevents components/operators from entering a hotloop and stuck.

There are already reported cases that have run into that issue and were stuck for hours or even days. For example https://bugzilla.redhat.com/show_bug.cgi?id=1877346.

The root cause of the issue is the fact that a watch cache is initialized from the global revision (etcd) and might stay on it for an undefined period (if no changes were (add, modify) made). 
That means that the watch cache across server instances may be out of sync. 
That might lead to a situation in which a client gets a resource version from a server that has observed a newer rv, disconnect (due to a network error) from it, and reconnect to a server that is behind, resulting in “Too large resource version“ errors.

More details in https://github.com/kubernetes/kubernetes/issues/91073 and https://github.com/kubernetes/enhancements/tree/master/keps/sig-api-machinery/1904-efficient-watch-resumption


It looks like the issue only affects 1.18. According to https://github.com/kubernetes/kubernetes/issues/91073#issuecomment-652251669 the issue was first introduced in that version by changes done to the reflector. 
The fix is already present in 1.19.


Please make sure that machine-api-operator is using a client-go that includes https://github.com/kubernetes/kubernetes/pull/92688 if not please use this BZ and file a PR.
In case you are using a framework to build your operator make sure it uses the right version of the client-go library.

Comment 1 Alberto 2020-09-18 12:16:06 UTC
Please lets leave this targeting 4.6. The clone for 4.5.z is https://bugzilla.redhat.com/show_bug.cgi?id=1880343 you can see that in the "Blocks" section.

Comment 3 sunzhaohua 2020-09-24 05:11:16 UTC
Verified 
clusterversion: 4.6.0-0.nightly-2020-09-23-022756
Checking client-go for machine-api-operator,
$ git clone git@github.com:openshift/machine-api-operator.git
$ cd machine-api-operator/
$ git checkout -b 4.6.0-0.nightly-2020-09-23-022756 e0db6b
$ grep 'k8s.io/client-go' go.mod 
	k8s.io/client-go v0.19.0
this is as expected version.

Comment 6 errata-xmlrpc 2020-10-27 16:42:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.