Bug 188034 - xterm color works when it shouldn't
xterm color works when it shouldn't
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 10:36 EDT by David A. De Graaf
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-13 16:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. De Graaf 2006-04-05 10:36:18 EDT
Description of problem:
xterm man page says    *customization: -color   is needed, but it isn't.

Version-Release number of selected component (if applicable):
xterm-211-1.FC5


How reproducible:
Always.


Steps to Reproduce:
1. Put  *customization: -color   into ~/.Xdefaults; start X;  start 
  xterm -bg red4   and observe a red background.

2. Remove   customization: -color   from ~/.Xdefaults; start X;  start
  xterm -bg red4   and observe a red background.

3.
  
Actual results:
  Color happens with or without the line.


Expected results:
The man page says the line is needed to get color.

Additional info:
The man page says this:
 /usr/lib/X11/app-defaults/XTerm-color
            the  xterm  color application resources.  If your display supports
            color, use this
                      *customization: -color
            in your .Xdefaults file to automatically turn on  color  in  xterm
            and similar applications.

Is this correct?  The program doesn't seem to know it.

BTW, color didn't work at all in xterm-209-4.i386.rpm, but it does work again
with the update - xterm-211-1.FC5.  Thanks for fixing it.  I found this man page
  anomaly while searching for a solution.
Comment 1 Thomas E. Dickey 2006-04-05 12:27:26 EDT
The manpage is wrong - the default (compiled-in) resource settings have
enabled color since 1999.
Comment 2 Jason Vas Dias 2006-04-13 16:35:30 EDT
Comment #1 is correct - xterm color mode operation is enabled by default.
The man-page merely states (correctly) that you can make xterm use different
color defaults by using the '*customization:-color' Xresource to select the
XTerm.color app-defaults file, instead of the XTerm app-default file - and
you can. Closing as 'NOTABUG'.
 

Note You need to log in before you can comment on or make changes to this bug.