Bug 1880387 - Tooltips in Firefox stop working after some time when on Wayland
Summary: Tooltips in Firefox stop working after some time when on Wayland
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 11:54 UTC by Daniel Rusek
Modified: 2021-05-25 16:45 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-25 16:45:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Daniel Rusek 2020-09-18 11:54:50 UTC
Description of problem:
Tooltips on websites displayed in Firefox seem to stop working after some time when on Wayland. This happens randomly, but happens (almost) every time after few hours when Firefox is running.

Version-Release number of selected component (if applicable):
firefox-80.0.1-2.fc32.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Use Firefox on Wayland GNOME Shell session.
2. Wait few hours (do not close Firefox window).
3. Try if tooltips (that are displayed when mouse hovering over some web elements that contain tooltip texts) are still working properly.

Actual results:
After some time, tooltips stop working when on Wayland.

Expected results:
Tooltips work properly.

Comment 1 Daniel Rusek 2020-09-18 21:32:18 UTC
I have also noticed that when the issue happens, tabs with pages in in the Firefox window cannot be dragged and rearranged.

Comment 2 Martin Stransky 2020-09-30 10:08:43 UTC
Yes, I do see that too, Thanks.

Comment 3 Dima Ryazanov 2021-02-04 22:24:24 UTC
I just noticed a sequence of actions that made tooltips and tab dragging work again. It's very bizarre, but worked twice for me so far, so here we go...

I (unsuccessfully) tried to remove a container:
- Opened about:preferences
- Searched for "container"
- Clicked "Settings..."
- Clicked "Remove" next to the container I was trying to get rid of
- Got a message "If you remove this Container now, 1 container tab will be closed. Are you sure you want to remove this Container?"
- Clicked "Remove this Container"

Nothing happens - the container is still there. But, tooltips are back, and tabs are draggable. Of course, for all I know, containers have nothing to do with it, and just opening "about:preferences" is sufficient - but I'll have to wait a few days for the bug to re-appear, so I can try it again.

Comment 4 Dima Ryazanov 2021-02-08 18:50:16 UTC
Just confirming that I'm not crazy: those steps worked for me for the third time. The last one doesn't matter, though - even if I clicked "x" to close the prompt, it fixed the tooltips and dragging.

Comment 5 Martin Stransky 2021-02-08 19:47:20 UTC
Upstream bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1683578

Thanks for your finding, I think the tooltip window is on some bad state and the steps causes it's re-creation - perhaps some widget three is broken and re-created.

Comment 6 Fedora Program Management 2021-04-29 16:38:08 UTC
This message is a reminder that Fedora 32 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 32 on 2021-05-25.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '32'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 32 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 7 Ben Cotton 2021-05-25 16:45:33 UTC
Fedora 32 changed to end-of-life (EOL) status on 2021-05-25. Fedora 32 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.