Bug 1880447 - [GSS] ocs-storagecluster-cephobjectstore.rgw.log pool not enabled for application rook-ceph-rgw
Summary: [GSS] ocs-storagecluster-cephobjectstore.rgw.log pool not enabled for applica...
Keywords:
Status: CLOSED DUPLICATE of bug 1852983
Alias: None
Product: Red Hat OpenShift Container Storage
Classification: Red Hat
Component: rook
Version: 4.4
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: ---
Assignee: Travis Nielsen
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 15:06 UTC by Priya Pandey
Modified: 2021-08-17 17:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 21:55:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Priya Pandey 2020-09-18 15:06:09 UTC
Description of problem (please be detailed as possible and provide log
snippests):


After instaaltion, ocs-storagecluster-cephobjectstore.rgw.log pool not enabled for application "rook-ceph-rgw".


Version of all relevant components (if applicable):

4.4.0


Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?

OCS cluster went to degraded state after installation:

# ceph health status :

HEALTH_WARN application not enabled on 1 pool(s)
POOL_APP_NOT_ENABLED application not enabled on 1 pool(s)
    application not enabled on pool 'ocs-storagecluster-cephobjectstore.rgw.log'
    use 'ceph osd pool application enable <pool-name> <app-name>', where <app-name> is 'cephfs', 'rbd', 'rgw', or freeform for custom applications.


Is there any workaround available to the best of your knowledge?


Manually enable the pool from ceph toolbox pod:


 # ceph osd pool application enable ocs-storagecluster-cephobjectstore.rgw.log rook-ceph-rgw


Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?

3

Can this issue reproducible?

In CU environment

Can this issue reproduce from the UI?

In CU environment

If this is a regression, please provide more details to justify this:

N/A


Actual results:

OCS cluster is in degraded state after installation.


Expected results:

OCS cluster should be in healthy after installation.


Additional info:

In next comments

Comment 3 Travis Nielsen 2020-09-21 21:55:01 UTC
The root cause is the same as https://bugzilla.redhat.com/show_bug.cgi?id=1852983.

In v4.4, the operator does not correctly wait to create the object store before the cluster is properly initialized, which results in rgw automatically creating the pools instead of waiting for Rook to create them with the expected application, replicas, and other settings. 

Since it's the same root cause, closing as a duplicate.

*** This bug has been marked as a duplicate of bug 1852983 ***


Note You need to log in before you can comment on or make changes to this bug.