Bug 1880494 - Helm release not showing workload in topology
Summary: Helm release not showing workload in topology
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 16:55 UTC by Jeff Phillips
Modified: 2020-10-27 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-09-18-071428 Cluster ID: 55a3a819-1038-462d-8020-f9288c70a905 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36
Last Closed: 2020-10-27 16:42:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6682 0 None closed Bug 1880494: Fix to show helm workloads in all helm releases 2020-09-23 11:15:14 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:15 UTC

Description Jeff Phillips 2020-09-18 16:55:33 UTC
Description of problem:

Helm releases don't always show the workload resources in the grouping.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. Install a few helm releases
2. Navigate to topology view

Actual results:

Helm release shows up without any workloads

Expected results:

All helm releases show their owned resource workloads

Additional info:

Comment 2 Jaivardhan Kumar 2020-09-23 11:18:03 UTC
Verified on 4.6.0-0.nightly-2020-09-22-213802 with latest UI

Comment 5 errata-xmlrpc 2020-10-27 16:42:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.