Bug 18806 - Cannot format disk
Cannot format disk
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 09:17 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 16:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-10 09:17:16 EDT
After  changing the second partition on a 30 gig drive to "/" for linux  I
got the warning message about the performance hit because it was a MS-DOS
FAT.  Accepted the warning, and pressed next.  
	A screen poped up and said there was a bug that needed to be reported.  I
copied  the report to floppy, and the machine began to reboot.  The first
part of the saved file says

Traceback (innermost last): {} File "/usr/bin/anaconda" line 438 , in ?{}
intf.run(todo, test = test)  ---More follows, but  the following is
probably the important part. 
frame{}:fstype:vfat:{} /mnt/space{}devName:
/tmp/hda5{}readonly{{}}device:/tmp/hda5{} {} ToDo object:  the number of
graphic characters becomes very large. 

The {} represents a graphic character block in the notepad display
Comment 1 Need Real Name 2000-10-10 09:27:09 EDT
Not thinking clearly,  I did move the floppy from the PC to the UNIX machine. 
Here is a past of the Traceback. 

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/rootpartition_gui.py", line
133, in getScreen
    avail = apply(isys.spaceAvailable, self.todo.fstab.getRootDevice())
  File "/usr/lib/anaconda/isys.py", line 10, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
fstype: vfat
location: /mnt/space
devName: /tmp/hda5
readOnly: 0
device: /tmp/hda5

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6


Comment 2 Michael Fulbright 2000-10-18 16:31:29 EDT
Almost certainly a dupe of 18032 - there is an errata for this problem.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.