Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1880629 - Fix support for pre-provisioned snapshots in Volume Snapshots
Summary: Fix support for pre-provisioned snapshots in Volume Snapshots
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Bipul Adhikari
QA Contact: Siva Reddy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 20:09 UTC by Bipul Adhikari
Modified: 2020-10-27 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:42:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
The screenshot with the fix showing source field (65.96 KB, image/png)
2020-09-22 11:56 UTC, Siva Reddy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6679 0 None closed Bug 1880629: Fixes support for pre-provisioned snapshots 2020-10-15 10:39:27 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:15 UTC

Description Bipul Adhikari 2020-09-18 20:09:16 UTC
Description of problem:
VS list shows only Persistent Volume claim as source and not volume snapshot content as source.

Version-Release number of selected component (if applicable):


How reproducible:1/1


Steps to Reproduce:
1. Create volume snapshot from Volume Snapshot Content
2. Go to List Page
3.

Actual results:
Doesn't show the source of Volume Snapshot

Expected results:
Should show the source of Volume Snapshot

Fix: Rename the PVC column to source and use the relevant resource. 

Additional info:

Comment 2 Siva Reddy 2020-09-22 11:53:39 UTC
The source field is not available and shows the correct source. Hence this bug is verified
attached the screenshots of the post fix as attachment

Steps to reproduce:
1. create a project, new app and a PVC to attach to a pod
2. create a volume snapshot class for the same provision-er as the PVC
3. create a volume snapshot for the above snap shot class

   Check that the volume snapshot details page shows the "source" field and it contains the PVC name. If the source is VSC then it should contain the VSC name.

Comment 3 Siva Reddy 2020-09-22 11:55:18 UTC
(In reply to Siva Reddy from comment #2)
> The source field is not available and shows the correct source. Hence this
> bug is verified
> attached the screenshots of the post fix as attachment
> 
> Steps to reproduce:
> 1. create a project, new app and a PVC to attach to a pod
> 2. create a volume snapshot class for the same provision-er as the PVC
> 3. create a volume snapshot for the above snap shot class
> 
>    Check that the volume snapshot details page shows the "source" field and
> it contains the PVC name. If the source is VSC then it should contain the
> VSC name.


version   4.6.0-0.nightly-2020-09-21-230455 the bug is verified in

Comment 4 Siva Reddy 2020-09-22 11:56:33 UTC
Created attachment 1715688 [details]
The screenshot with the fix showing source field

Comment 7 errata-xmlrpc 2020-10-27 16:42:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.