Bug 1880683 - origin: etcd leader changes are not excessive test is not actionable
Summary: origin: etcd leader changes are not excessive test is not actionable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-19 01:01 UTC by Sam Batschelet
Modified: 2020-10-27 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:42:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25524 0 None closed Bug 1880683: test/extended/etcd: make excessive leader_change test actionable 2020-09-28 01:56:51 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:15 UTC

Description Sam Batschelet 2020-09-19 01:01:45 UTC
Description of problem: the current test is nonactionable below is the output of the test.

```
fail [github.com/openshift/origin/test/extended/etcd/leader_changes.go:24]: Expected
    <model.SampleValue>: 1.0714285714285714
to be ==
    <int>: 0
```

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.
2.
3.

Actual results: the test failure should inform folks about the possible reasons for the test and how to triage.


Expected results: test output gives a clear signal to the failure reason and helps triage root cause.


Additional info:

Comment 2 ge liu 2020-09-28 04:09:31 UTC
I suppose this is e2e test improvement.

Comment 5 errata-xmlrpc 2020-10-27 16:42:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.