Bug 1880708 - The base environemnt is invalid
Summary: The base environemnt is invalid
Alias: None
Product: Fedora
Classification: Fedora
Component: conda
Version: 33
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2020-09-19 06:26 UTC by proletarius101
Modified: 2020-09-22 04:58 UTC (History)
2 users (show)

Fixed In Version: conda-4.8.5-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-09-22 02:12:17 UTC
Type: Bug

Attachments (Terms of Use)

Description proletarius101 2020-09-19 06:26:08 UTC
Description of problem:
The base environment is set to be in `/usr`, where conda has no permission to write anything into.

Moreover, it's strange that we have to append `-c base` to every conda command whereas the expected behavior is that the default env is selected automatically.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. conda install argcomplete -c base

Actual results:

NoBaseEnvironmentError: This conda installation has no default base environment. Use
'conda create' to create new environments and 'conda activate' to
activate environments.

Expected results:
argcomplete gets installed

Additional info:

Comment 1 Orion Poplawski 2020-09-19 20:36:10 UTC
This is pretty much how it is expected to work in Fedora.  You can use conda to create and manage new environments, but it doesn't replace dnf for managing the system.  Let us know where you think this should be better documented (i.e. where would you have looked?).

Also, I'm not quite sure what you mean about having to add -c base, I get the same error with out it. :)

Comment 2 proletarius101 2020-09-20 05:15:31 UTC
> Also, I'm not quite sure what you mean about having to add -c base, I get the same error with out it. :)

Oh, that should be -n I think. I just want to switch to the base env.

> i.e. where would you have looked?

Maybe https://developer.fedoraproject.org/tech/languages/python/scipy.html. Or simply in the description of conda (such that dnf info shows it). Or when it prompt to initialize the base env, explain that we should actually create new env instead of using the base env.

Comment 3 Orion Poplawski 2020-09-22 02:12:17 UTC
I've added a note to the description:

The Fedora conda base environment is special.  Unlike a standard
anaconda install base environment it is essentially read-only.  You
can only use conda to create and manage new environments.

and while the error message above is a bit strange, it is essentially correct - use conda create to make a new environment.

Comment 4 proletarius101 2020-09-22 04:58:44 UTC
Thanks! That looks good.

Note You need to log in before you can comment on or make changes to this bug.