Bug 188071 - ps2pdf corrupts some embedded eps images
ps2pdf corrupts some embedded eps images
Status: CLOSED DUPLICATE of bug 187834
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 15:02 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 15:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture referenced by the .tex file (133.11 KB, image/x-eps)
2006-04-05 15:02 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2006-04-05 15:02:11 EDT
Description of problem:
Some (but not all!) eps images embedded in .ps files using LaTeX's epsfig are
corrupted when the .ps file is converted to .pdf using ps2pdf.

Version-Release number of selected component (if applicable):
ghostscript-8.15.1-7

How reproducible:
Every time

Steps to Reproduce:
1.latex bug.tex && dvips -Ppdf -o bug.ps bug.dvi && ps2pdf bug.ps
2.display ShadowMe.eps; evince bug.ps; evince bug.pdf; display bug.ps; display
bug.pdf; xpdf bug.pdf

Actual results:
The .eps and .ps files are correct, but in the .pdf file, the bottom of the
picture is cut out.  On ImageMagick's display bug.pdf, the bottom is not just
cut out, it's actually replaced with visual noise.

Expected results:
The pdf should look the same on .ps and .pdf.

Additional info:
Here's the latex source file:
$ cat bug.tex
\documentclass{seminar}
\usepackage{epsfig}
\begin{document}
\epsfig{figure=ShadowMe.eps}
\end{document}

The .eps file it references is attached.

I couldn't figure out what it is that triggers the bug, but it only hits for
certain particular images.  When it does, it reproducibly hits on such images,
on both i386 and x86_64, FC5 and rawhide.

The bug is not present on FC4.
Comment 1 Alexandre Oliva 2006-04-05 15:02:12 EDT
Created attachment 127367 [details]
Picture referenced by the .tex file
Comment 2 Alexandre Oliva 2006-04-05 15:06:36 EDT

*** This bug has been marked as a duplicate of 187834 ***

Note You need to log in before you can comment on or make changes to this bug.