Bug 1880778 - file conflict between gst-transcoder and gstreamer1-plugins-bad-free
Summary: file conflict between gst-transcoder and gstreamer1-plugins-bad-free
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer1-plugins-bad-free
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-09-19 21:49 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2020-09-25 17:02 UTC (History)
9 users (show)

Fixed In Version: gstreamer1-plugins-bad-free-1.18.0-3.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-25 17:02:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2020-09-19 21:49:51 UTC
During upgrade to F33:
  file /usr/bin/gst-transcoder-1.0 conflicts between attempted installs of gst-transcoder-1.16.0-4.fc33.x86_64 and gstreamer1-plugins-bad-free-1.18.0-2.fc33.x86_64                                 file /usr/lib64/gstreamer-1.0/libgsttranscode.so conflicts between attempted installs of gst-transcoder-1.16.0-4.fc33.x86_64 and gstreamer1-plugins-bad-free-1.18.0-2.fc33.x86_64                 file /usr/lib64/libgsttranscoder-1.0.so.0 conflicts between attempted installs of gst-transcoder-1.16.0-4.fc33.x86_64 and gstreamer1-plugins-bad-free-1.18.0-2.fc33.x86_64

Comment 1 Fedora Blocker Bugs Application 2020-09-19 21:50:19 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user zbyszek using the blocker tracking app because:

 Break upgrade to F33.

Comment 2 Kamil Páral 2020-09-21 10:51:08 UTC
I can confirm this, both packages can't be installed at the same time on F33.

Comment 3 Adam Williamson 2020-09-21 19:08:32 UTC
Discussed at 2020-09-21 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2020-09-21/f33-blocker-review.2020-09-21-16.00.html . Accepted as a freeze exception issue as this affects upgrades and it's good to fix such issues as soon as possible for people who try to upgrade before 0-day updates go out.

Comment 4 Gwyn Ciesla 2020-09-21 19:58:47 UTC
Retired gst-transcoder in f34 and f33, is it's been merged into gstreamer1-plugins-bad-free.

Comment 5 Adam Williamson 2020-09-21 20:46:12 UTC
Well, then gstreamer1-plugins-bad-free should obsolete/provide it, too. It doesn't look like that's been done.

Comment 6 Gwyn Ciesla 2020-09-21 20:49:41 UTC
I agree. If that maintainer is unwilling/unable to do so I can take care of it.

Comment 7 Kamil Páral 2020-09-22 08:45:19 UTC
Gwyn, I'm sorry, why has this been closed? It's not fixed yet, is it? It will need a Bodhi update first.

Comment 8 Gwyn Ciesla 2020-09-22 13:07:18 UTC
It shouldn't, it was just a package retirement. The Obsoletes/Provides above would require a bodhi update, but the retirement to fix the conflict should apply after a compose.

Comment 9 Zbigniew Jędrzejewski-Szmek 2020-09-22 13:32:47 UTC
Yeah, we need the Obsoletes because this will still block upgrades if people have the old package
installed.

(In reply to Gwyn Ciesla from comment #6)
> I agree. If that maintainer is unwilling/unable to do so I can take care of it.

I'm not sure if @bpepple is listening. If you could do it for the sake of expediency that'd be great.

Comment 10 Gwyn Ciesla 2020-09-22 13:49:02 UTC
On it, update coming.

Comment 11 Fedora Update System 2020-09-22 14:39:44 UTC
FEDORA-2020-b8f432bee5 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b8f432bee5

Comment 12 Fedora Update System 2020-09-23 15:26:23 UTC
FEDORA-2020-b8f432bee5 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b8f432bee5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b8f432bee5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-09-25 17:02:48 UTC
FEDORA-2020-b8f432bee5 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.