Bug 188092 - "Auto-run programs on new drives and media" doesn't work
"Auto-run programs on new drives and media" doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On: 188091
Blocks: FC7Target FC6Update
  Show dependency treegraph
 
Reported: 2006-04-05 18:48 EDT by Christopher Aillon
Modified: 2013-03-05 22:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 15:01:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2006-04-05 18:48:12 EDT
Description of problem:

System>Preferences>Removable Drives and Media

If you check "Auto-run programs on new drives and media", this doesn't actually
have any effect because gnome-mount mounts items with noexec.  We should figure
out a better solution here.

gnome-mount-0.4-5
Comment 1 David Zeuthen 2006-04-05 23:09:57 EDT
Yup, we should fix this.

See also my comments to bug 188091 which is blocking this one.
Comment 2 David Zeuthen 2006-09-28 19:33:29 EDT
Actually in Rawhide with gnome-mount 0.5 and hal 0.5.8.1 you can now do

 gnome-mount -d /dev/sda1 -oremount,exec

which g-v-m should do when wanting to run programs on some media. Reassigning to
g-v-m so we can fix this during FC7.
Comment 3 Matthias Clasen 2007-04-17 15:01:24 EDT
This is fixed in the current packages, according to David.

Note You need to log in before you can comment on or make changes to this bug.