Bug 1880944 - Pod creation dry-run fails, 'admission webhook "pod-identity-webhook.amazonaws.com" does not support dry run'
Summary: Pod creation dry-run fails, 'admission webhook "pod-identity-webhook.amazonaw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.6.0
Assignee: Seth Jennings
QA Contact: wang lin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-21 08:21 UTC by Marek Schmidt
Modified: 2020-10-27 16:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:42:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 249 0 None closed Bug 1880944: aws-pod-identity: add sideEffects to webhook 2020-09-28 16:53:57 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:22 UTC

Description Marek Schmidt 2020-09-21 08:21:45 UTC
Description of problem:
With current OCP 4.6 nightly on AWS (IPI)

Running a dry-run on a Pod creation fails

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-09-21-030155 on AWS (IPI)

How reproducible:
Always

Steps to Reproduce:
1. Install OCP 4.6 on AWS (IPI)
2.

oc create --dry-run=server -f - <<EOF
apiVersion: v1
kind: Pod
metadata:
  name: hello
spec:
  containers:
  - image: docker.io/openshift/hello-openshift
    name: hello
EOF


Actual results:

Error from server (BadRequest): error when creating "STDIN": admission webhook "pod-identity-webhook.amazonaws.com" does not support dry run

Expected results:

pod/hello created (server dry run)

Additional info:

This is a regression, works fine on OCP 4.5.9

Comment 1 Seth Jennings 2020-09-22 14:18:54 UTC
xref upstream issue https://github.com/aws/amazon-eks-pod-identity-webhook/issues/46

Comment 2 Devan Goodwin 2020-09-22 14:38:57 UTC
Seth informed us this regressed because the webhook was not registered in 4.5, but now is in 4.6, and given the upstream shortcoming linked above the problem now surfaces.

Trying to confirm if this is a release blocker or not with Scott Dodson now.

Comment 3 Seth Jennings 2020-09-22 17:05:57 UTC
fix confirmed

$ oc create --dry-run=server -f - <<EOF
> apiVersion: v1
> kind: Pod
> metadata:
>   name: hello
> spec:
>   containers:
>   - image: docker.io/openshift/hello-openshift
>     name: hello
> EOF
pod/hello created (server dry run)

Comment 5 wang lin 2020-09-24 13:42:59 UTC
The bug has fixed.
test payload: 4.6.0-0.nightly-2020-09-24-015627

$ oc create --dry-run=server -f - <<EOF
> apiVersion: v1
> kind: Pod
> metadata:
>   name: hello
> spec:
>   containers:
>   - image: docker.io/openshift/hello-openshift
>     name: hello
> EOF
pod/hello created (server dry run)

Comment 8 errata-xmlrpc 2020-10-27 16:42:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.