Bug 1881080 - 3.0.0-1.fc33 breaks sound on MS/Windows guests. Works for 2.2.1-3.fc32
Summary: 3.0.0-1.fc33 breaks sound on MS/Windows guests. Works for 2.2.1-3.fc32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 33
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1883658 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-21 13:59 UTC by Tom London
Modified: 2020-10-03 00:56 UTC (History)
4 users (show)

Fixed In Version: virt-manager-3.1.0-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-03 00:56:33 UTC
Type: Bug


Attachments (Terms of Use)
'virt-manager --debug' for 3.0.0-1.fc33 running 32-bit Windows 10 guest (18.02 KB, text/plain)
2020-09-21 15:01 UTC, Tom London
no flags Details
'virt-manager --debug' for 2.2.1-3.fc32 running 32-bit Windows 10 guest (19.07 KB, text/plain)
2020-09-21 15:06 UTC, Tom London
no flags Details

Description Tom London 2020-09-21 13:59:37 UTC
Description of problem:
3.0.0-1.fc33 breaks sound for my MS/Windows VMs. Although the guest seems to show that sound device/settings are working, no sound is produced.

Sound does work on a Rawhide VM though.

Downgrading to 2.2.1-3.fc32 "makes  it work for me".


Version-Release number of selected component (if applicable):
virt-manager\*-3.0.0-1.fc33

How reproducible:
Every time


Steps to Reproduce:
1. Upgrade to 3.0.0-1.fc33
2. Start MS/Windows VM
3. Try to get sounds....

Actual results:
Silence

Expected results:
Sound

Additional info:
Fails for both 32- and 64-bit MS/Windows guests.
Host is running 5.8.10-300.fc33.x86_64; "updates-testing" upgrades.

Comment 1 Cole Robinson 2020-09-21 14:24:00 UTC
Thanks for the report, I will try to reproduce.

Can you reproduce with `virt-manager --debug` and see if there's any errors printed? Or just post the full output of running the app, starting your windows VM, do something in the VM that should generate sound, then shutdown virt-manager

Comment 2 Tom London 2020-09-21 15:01:19 UTC
Created attachment 1715548 [details]
'virt-manager --debug' for 3.0.0-1.fc33 running 32-bit Windows 10 guest

I updated virt-manager and friends and ran 'virt-manager --debug'.

Comment 3 Tom London 2020-09-21 15:06:31 UTC
Created attachment 1715549 [details]
'virt-manager --debug' for 2.2.1-3.fc32 running 32-bit Windows 10 guest

For reference, here is debug output after downgrading to 2.2.1-3.fc32 and running the same 'script': I booted, (heard Windows tones on bootup), started game (and heard sounds) and quit game.

Comment 4 Cole Robinson 2020-09-21 19:00:59 UTC
Thanks for the info. I managed to reproduce. It's strange that it works for win7 and linux but not win10, I expected this to behave all transparently to the guest OS

Anyways it's fixed now upstream. I removed a bit of code on 3.0.0 that looked pointless but apparently it does something! *shrug*

I'll do a Fedora build this week

commit 79ebcbcb71d77548443b7943d65bacb216c93769 (origin/master, origin/HEAD, master)
Author: Cole Robinson <crobinso>
Date:   Mon Sep 21 11:35:51 2020 -0400

    viewers: Fix spice audio

Comment 5 Tom London 2020-09-21 20:20:34 UTC
Thanks for the quick response!

Comment 6 Cole Robinson 2020-09-30 10:25:32 UTC
*** Bug 1883658 has been marked as a duplicate of this bug. ***

Comment 7 Vasiliy Glazov 2020-09-30 18:57:01 UTC
Any problems with doing new build?

Comment 8 Fedora Update System 2020-09-30 22:28:49 UTC
FEDORA-2020-c30055ffe4 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c30055ffe4

Comment 9 Fedora Update System 2020-10-01 01:20:49 UTC
FEDORA-2020-c30055ffe4 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c30055ffe4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c30055ffe4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Tom London 2020-10-01 14:06:48 UTC
Thanks!

virt-\*-3.1.0-1.fc33.noarch makes sound work for Win10 guests for me@!

Comment 11 Fedora Update System 2020-10-03 00:56:33 UTC
FEDORA-2020-c30055ffe4 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.