Bug 1881135 - Deprecate mongodb imagestreams and templates
Summary: Deprecate mongodb imagestreams and templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.6
Hardware: All
OS: Linux
urgent
high
Target Milestone: ---
: 4.6.0
Assignee: Yaakov Selkowitz
QA Contact: XiuJuan Wang
URL:
Whiteboard:
: 1882455 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-21 15:25 UTC by Yaakov Selkowitz
Modified: 2020-10-27 16:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:43:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 327 0 None closed Bug 1881135: remove mongodb templates 2020-09-28 02:03:36 UTC
Github openshift origin pull 25528 0 None closed Bug 1881135: image_ecosystem: remove mongodb tests 2020-09-27 03:14:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:51 UTC

Description Yaakov Selkowitz 2020-09-21 15:25:39 UTC
Tracker for PRs to deprecate mongodb imagestreams and templates.

Comment 3 Adam Kaplan 2020-09-24 15:58:37 UTC
*** Bug 1882455 has been marked as a duplicate of this bug. ***

Comment 5 XiuJuan Wang 2020-09-28 02:03:29 UTC
Validate on x86_64 arch with 4.6.0-0.nightly-2020-09-27-075304 version.

The template "nodejs-mongodb-example" will be kept in purpose, right?
$oc get template -n openshift | grep mongodb 
nodejs-mongodb-example                              An example Node.js application with a MongoDB database. For more information...    18 (4 blank)      8


New added templates work well:
nodejs-postgresql-example 
nodejs-postgresql-persistent

Samples operator is running well in the new installation and upgrade from 4.5.

Comment 6 Yaakov Selkowitz 2020-09-29 03:35:49 UTC
Yes, nodejs-mongodb-example was kept on purpose because we ran out of time to update all the tests which depend thereon.  It is marked hidden though and therefore shouldn't show up in the console.

Comment 7 XiuJuan Wang 2020-09-29 05:35:02 UTC
Thanks for confirming
Move this bug to verified.

Comment 10 errata-xmlrpc 2020-10-27 16:43:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.