Bug 1881142 - chromium cannot access network
Summary: chromium cannot access network
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: chromium
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1881317 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-21 15:38 UTC by Orion Poplawski
Modified: 2020-10-10 21:11 UTC (History)
7 users (show)

Fixed In Version: chromium-85.0.4183.121-1.el7 chromium-85.0.4183.121-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-25 16:34:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Orion Poplawski 2020-09-21 15:38:26 UTC
Description of problem:

I cannot access an websites via chromium.  Firefox and google-chrome work.

Version-Release number of selected component (if applicable):
chromium-85.0.4183.102-1.el7.x86_64

$ chromium-browser --verbose                                                        
Received signal 11 SEGV_MAPERR ffffffffffffffe9                                                    
#0 0x5644afea68f9 base::debug::CollectStackTrace()
#1 0x5644afe1ca76 base::debug::StackTrace::StackTrace()
#2 0x5644afea629a base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x5644afea688e base::debug::(anonymous namespace)::StackDumpSignalHandler()
#4 0x7f38b4d41630 (/usr/lib64/libpthread-2.17.so+0xf62f)
#5 0x5644b02add0f net::CookieMonster::InternalInsertCookie()
#6 0x5644b02b5d6e net::CookieMonster::StoreLoadedCookies()
#7 0x5644b02b6029 net::CookieMonster::OnKeyLoaded()
#8 0x5644b02a98d0 base::internal::Invoker<>::RunOnce()
#9 0x5644b1440c59 network::SessionCleanupCookieStore::OnLoad()
#10 0x5644b143f603 base::internal::Invoker<>::RunOnce()
#11 0x5644b1495565 net::SQLitePersistentCookieStore::CompleteKeyedLoad()
#12 0x5644b149539a base::internal::Invoker<>::RunOnce()
#13 0x5644b14964c2 net::SQLitePersistentCookieStore::Backend::Notify()
#14 0x5644b14965ae net::SQLitePersistentCookieStore::Backend::CompleteLoadForKeyInForeground()
#15 0x5644b1494d26 base::internal::Invoker<>::RunOnce()
#16 0x5644afe71542 base::TaskAnnotator::RunTask()
#17 0x5644afe83975 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoWorkImpl()
#18 0x5644afe83d8e base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoWork()
#19 0x5644afec8db1 base::MessagePumpLibevent::Run()
#20 0x5644afe832d5 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::Run()
#21 0x5644afe571d6 base::RunLoop::Run()
#22 0x5644afe9296b base::Thread::ThreadMain()
#23 0x5644afeb8305 base::(anonymous namespace)::ThreadFunc()
#24 0x7f38b4d39ea5 start_thread
#25 0x7f38adedb8dd __clone
  r8: 00007f38a0a53d20  r9: 0000000000000000 r10: 00001b565aa0fbd0 r11: 00007f38adf6b4d0
 r12: 00001b565aae53c0 r13: 00001b565aac3690 r14: 00001b565aaafbb8 r15: 0000000000000001
  di: 0000000000000001  si: 00001b565aac36d8  bp: 00007f38a0a54100  bx: 00001b565aaafb40
  dx: 00001b565aaafbb8  ax: 00001b565aaafbb8  cx: 00005644b855c980  sp: 00007f38a0a54060
  ip: 00005644b02add0f efl: 0000000000010246 cgf: 0000000000000033 erf: 0000000000000005
 trp: 000000000000000e msk: 0000000000000000 cr2: ffffffffffffffe9
[end of stack trace]
Calling _exit(1). Core file will not be generated.
[3427:3427:0921/092916.701931:ERROR:network_service_instance_impl.cc(264)] Network service crashed, restarting service.

Comment 1 Tom "spot" Callaway 2020-09-21 18:49:35 UTC
Can reproduce. Now to figure out why. :/

Comment 2 Tom "spot" Callaway 2020-09-22 14:32:28 UTC
*** Bug 1881317 has been marked as a duplicate of this bug. ***

Comment 3 Justin Sherrill 2020-09-22 17:38:08 UTC
I've been able to reproduce pretty easily.  

Install a minimum centos 7
enable epel
install chromium & chromium-headless
run: /usr/bin/chromium-browser --headless http://redhat.com


I've reproduce on both rhel 7 and centos 7, and i've also reproduced over vnc in non-headless mode.  In this 'headed mode', the browser will open and show the default google screen, but trying to browse anywhere results in that error.

Comment 4 Justin Sherrill 2020-09-22 17:39:20 UTC
oh sorry, i misread "can" as "can't"  ;)

Comment 5 Tom "spot" Callaway 2020-09-22 18:11:21 UTC
This should be fixed in chromium-85.0.4183.121-1.el7, which is now building in koji. I found the issue and it was already fixed upstream, so it was a simple patch backport.

Comment 6 Tom "spot" Callaway 2020-09-23 16:04:06 UTC
This is fixed in https://koji.fedoraproject.org/koji/buildinfo?buildID=1614348

The official update is waiting on the other branches to build, but I've confirmed that these packages resolve the issue.

Comment 7 Justin Sherrill 2020-09-23 18:11:34 UTC
I can confirm this resolves the issue for me

Comment 8 Fedora Update System 2020-09-24 19:53:48 UTC
FEDORA-EPEL-2020-1790461e43 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-1790461e43

Comment 9 Fedora Update System 2020-09-24 19:53:49 UTC
FEDORA-EPEL-2020-72907017c2 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-72907017c2

Comment 10 Fedora Update System 2020-09-25 16:34:52 UTC
FEDORA-EPEL-2020-72907017c2 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-09-25 17:49:36 UTC
FEDORA-EPEL-2020-1790461e43 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-1790461e43

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-10-10 21:11:29 UTC
FEDORA-EPEL-2020-1790461e43 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.